POJ3292--Semi-prime H-numbers

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are theH-numbers. For this problem we pretend that these are the only numbers. TheH-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units,H-primes, and H-composites. 1 is the only unit. AnH-number h is H-prime if it is not the unit, and is the product of twoH-numbers in only one way: 1 × h. The rest of the numbers areH-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly twoH-primes. The two H-primes may be equal or different. In the example above, all five numbers areH-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of threeH-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62
/*
H-numbers是所有模4余1的数
H-numbers也分素数和复数
由两个素数相乘得到的叫做迷你数
给一个H。求迷你数的个数
需要用筛法筛选出1000000这里的素数。
筛完再筛掉%4!=1的数,剩下的就是可以用的素数了。
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
using namespace std;
#define maxn 1000008
bool A[maxn]={0};
int B[120000];
int C[maxn];
bool vis[maxn];
set <int> coll;
int main()
{
	for(int i=2;i*i<=maxn;i++)
	{
		if(!A[i]&&i%4==1)
		{
			int k=1;
			for(int j=i*5;j<=maxn;j=i*k)//注意在H数的世界里筛法要适当修改。因为不会有234这些倍数
			{
				A[j]=1;
				k+=4;
			}
		}
	}
	A[1]=1;
	int k=0;
	for(int i=1;i<=maxn;i+=4)//20多W次运算
	{
		if(!A[i])B[++k]=i;
	}
	int j=2;
	int t=0;
	for(int i=1;i<=k;i++)
	{
		for(int j=1;j<=k;j++)
		{
			if(B[i]*B[j]>maxn)break;
			if(!vis[B[i]*B[j]])
			{
				vis[B[i]*B[j]]=1;
				C[++t]=B[i]*B[j];
			}
		}
	}
	sort(C+1,C+1+t);
	int n;
	while(scanf("%d",&n)!=EOF&&n)
	{
		int l=1,r=t;
		while(l<r)//二分搜索。
		{
			int mid=(l+r)/2;
			if(C[mid]>=n)
			{
				r=mid;
			}
			else l=mid+1;
		}
		if(C[l]<=n)
		cout<<n<<" "<<l<<endl;
		else cout<<n<<" "<<l-1<<endl;
	}
	return 0;
}
 
 
 
 
 
做法二:
#include <iostream>
#include <cstdio>
using namespace std;
#define maxn 1000008
bool Hprime[maxn]={0};
bool minih[maxn]={0};
int sum[maxn];
int main()
{
 for(int i=5;i<=maxn;i+=4)
 {
  for(int j=5;j<=maxn;j+=4)
  {
   if(i*j>maxn)break;
   if(!Hprime[i]&&!Hprime[j])//如果这两个都是素数
   {
    minih[i*j]=1;
   }
   else minih[i*j]=0;
   Hprime[i*j]=1;
  }
 }
 int count=0;
 for(int i=1;i<=maxn;i+=4)
 {
  if(minih[i])count++;
  sum[i]=count;
 }
 int n;
 while(scanf("%d",&n)!=EOF&&n)
 {
  printf("%d %d\n",n,sum[n]);
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值