ACM: 一道有待优化的题 poj3292

 

Semi-prime H-numbers

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21

85

789

0

Sample Output

21 0

85 5

789 62

题意: 在4n+1的序列中定义: Partition H-numbers into H-primes and H-composites

           1.H-primes: 是 4n+1序列中的素数.

2.H-composites: 4n+1序列中除了H-primes和1之外的数.

3.H-semi-primes: 由两个H-primes乘积而得.

4.输入H-numbers 输出H-numbers以内的H-semi-primes的个数.

个人思路:

1.最笨的方法了,打表了.

2.个人比较笨,把4n+1序列和序列中的素数分开来打表.

3.计算个数.

 

代码:

#include <cstdio>
#include <iostream>
#include <math.h>
#include <string.h>
using namespace std;
#define MAX 1000010


int ans[MAX] = {0};
int h[MAX] = {0};
int num[MAX] = {0};

void init()
{
        int i , j;
        int m = sqrt((double)MAX);

for(i = 1; i < MAX; i += 4)
              h[i] = 1;

for(i = 5; i <= m; i += 4)
       {
              for(j = i*i; j < MAX; j += i)
             {
                    h[j] = 0;
             }
       }

for(i = 5; i < m; i += 4)
       {
             if(h[i] == 1 && ans[i] == 0)
            {
                  for(j = i; i*j < MAX; j += 4)
                 {
                       if(h[j] == 1)
                      {
                            ans[i*j] = 1;
                      }
                  }
              }
         }

int k = 0;
       for(i = 1; i < MAX; ++i)
      {
             if(ans[i] == 1)
            {
                 num[i] = ++k;
            }
            else
           {
                 num[i] = k;
            }
        }
}


int main()
{
      init();
      int n;

//    freopen("a.txt","r",stdin);
//    printf("%lf\n",(double)clock()/CLOCKS_PER_SEC);
      while(cin >> n)
     {
           if(n == 0)
                break;
           printf("%d %d\n",n,num[n]);
      }

return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值