Semi-prime H-numbers - poj3292 - 筛数

Semi-prime H-numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10785 Accepted: 4838

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers areH-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

Source

Waterloo Local Contest, 2006.9.30

题意:

H-numbers是模4余1的数。

H-numbers可分为,units,H-primes和H-composites

"An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h."

H-primes是只能被1和h整除以的数,h是H-numbers,也就是说,H-primes是不为1的且不能被H-numbers整除以的数,这里不是和素数的意义相似吗,可以类似素数的筛法给筛出来。

比如9=1*9=3*3是H-primes因为3不是H-numbers。

H-semi-primes是一个H-number,并且是两个H-primes的乘积,两个H-primes可以相等。

思路:

读懂了题目这题就挺简单了,这里可以用筛素数的方法去筛H-primes,然后两个for循环枚举所有的H-primes相乘,(范围要对),然后用一个数组记录从[1,x]区间内的H-semi-primes的个数。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring> 
#include<queue>
#include<cmath>
using namespace std;
const int maxn=1000001;
int H_prime[maxn],H_semi_prime[maxn],tot[maxn];

void solve(){
	memset(H_prime,0,sizeof(H_prime));
	memset(H_semi_prime,0,sizeof(H_semi_prime));
	for(int i=5;i<=maxn;i+=4){
		 H_prime[i]=1;
	}
	
	for(int i=2;i<=maxn;i++){
		if(H_prime[i]){
			for(int j=2*i;j<=maxn;j+=i)H_prime[j]=0;
		}
	}
	for(int i=1;i<=maxn;i++){
		for(int j=1;j<=maxn;j++){
			if(i*j>maxn)break;
			if(H_prime[i]&&H_prime[j])H_semi_prime[i*j]=1;
		}
	}
	int cnt=0;
	for(int i=1;i<=maxn;i++){
		if(H_semi_prime[i])cnt++;
		tot[i]=cnt;
	}
}

int main(){
	int n;
	solve();
	while(scanf("%d",&n)){
		if(n==0)break;
		printf("%d %d\n",n,tot[n]);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值