table tennis ╮(╯▽╰)╭

Problem Description

There are N table tennis, and only one of them has quality problem which is lighter than a normal ball. Give you a balance without any weights, calculate the minimum number of times that you can guarantee to find the bad one.

Input

Multiple cases. Each case is a single integer n (1<=n<=1000).

Output

the minimum number of times that you can guarantee to find the bad one.

Sample Input

2
6

Sample Output

1
2

 

#include <iostream>
using namespace std;
int f[1002];
int main()
{
	f[0]=0;
	f[1]=0;
	f[2]=1;
	f[3]=1;
	for(int i=4;i<=1000;i++)
	{
		if((i/3)*3<i)
		{
			f[i]=f[i/3+1]+1;
		}
		else f[i]=f[i/3]+1;
	}
	int a;
	while(scanf("%d",&a)!=EOF)
	{
		cout<<f[a]<<endl;
	}
	return 0;

}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值