Table tennis

Table tennis

(Input File: table.in / Standard Output)

The 49th World Table Tennis Championships was held in Guangzhou from February 24th to March 2nd. It was a chance not to be missed for the table tennis enthusiast. TZD and other table tennis enthusiast in Zhongshan University decided to watch the first day’s matches. That day when they got to the gymnasium, there was still an hour left. So they decided to walk around. They found that not far away there were some children playing games round a table. This game was played like this: you stand by the table on one side, and on the other side there is a machine to serve you the balls one by one. Then you hit

the balls. See figure 2.9.1.

Figure 2.9.1 table tennis
On the half of the table opposite to you, there are three circles of different size. From left to right, see figure 2.9.2, we call them big circle, middle circle and small circle. If you hit the ball onto the area inside the big circle, you will get one point. For the middle circle you will get two points. And for the small circle three points. But if you hit the ball right onto the boundary of circles, you will not get any points. If you get enough points, you will be given a small gift! TZD also wanted to have a try.

Figure 2.9.2 the three circles
We assume that the circles are given by three integer (x- coordinate of the centre, y- coordinate of the centre, radius). From left to right the three circles are(30, 30, 20),(100, 30, 10),(170, 30, 5). And each hit is described by two integer (xpos, ypos), meaning that
TZD hit the ball onto the position (xpos, ypos). Now please tell TZD how many points he got after N hits.

Input:

The first line contains a positive integer T. T is the number of test cases followed.
For each test case, there is a positive integer N (0<=N<=60) in the first line, the number of TZD’s hits. Next come N pairs of integer (xpos, ypos), each pair in one line.(0<=xpos<=200, 0<=ypos<=100).

Output:

For each test case, print the total points in one line.

Sample input:

3
2
30 31
100 32
1
30 50
3
30 30
99 30
170 30

Sample output:

3
0
6

水题一道,但是英语不好,害到WA了两次。。。
AC代码:

#include <iostream>
#include <cstring>
using namespace std;
int fun(long long x,long long y)
{
    if(x*x+y*y-60*(x+y)+1400<0)
        return 1;
    else if(x*x+y*y-200*x-60*y+10800<0)
        return 2;
    else if(x*x+y*y-340*x-60*y+29775<0)
        return 3;
    return 0;
}
int main()
{
    int n,m,i;
    long long j,k;
    int cnt;
    cin >> n;
    while (n--)
    {
        cnt=0;
        cin >> m;
        for (i=0;i<m;++i)
        {
            cin >> j >> k;
            cnt+=fun(j,k);
        }
        cout << cnt << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
The following is the data that you can add to your input file (as an example). Notice that the first line is going to be a line representing your own hobbies. In my case, it is the Vitaly,table tennis,chess,hacking line. Your goal is to create a class called Student. Every Student will contain a name (String) and an ArrayList<String> storing hobbies. Then, you will add all those students from the file into an ArrayList<Student>, with each Student having a separate name and ArrayList of hobbies. Here is an example file containing students (the first line will always represent yourself). NOTE: eventually, we will have a different file containing all our real names and hobbies so that we could find out with how many people each of us share the same hobby. Vitaly,table tennis,chess,hacking Sean,cooking,guitar,rainbow six Nolan,gym,piano,reading,video games Jack,cooking,swimming,music Ray,piano,video games,volleyball Emily,crochet,drawing,gardening,tuba,violin Hudson,anime,video games,trumpet Matt,piano,Reading,video games,traveling Alex,swimming,video games,saxophone Roman,piano,dancing,art Teddy,chess,lifting,swimming Sarah,baking,reading,singing,theatre Maya,violin,knitting,reading,billiards Amy,art,gaming,guitar,table tennis Daniel,video games,tennis,soccer,biking,trumpet Derek,cooking,flute,gaming,swimming,table tennis Daisey,video games,guitar,cleaning,drawing,animated shows,reading,shopping Lily,flute,ocarina,video games,baking Stella,roller skating,sudoku,watching baseball,harp Sophie,viola,ukulele,piano,video games
06-10

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值