Table Tennis

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:
9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2
Sample Output:
08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2



#include <iostream>
#include <vector>
#include <queue>
#include <list>
#include <utility>
#include <string>
#include <algorithm>
using namespace std;
#define INFINITY 10000
bool comp(pair<int,int> a,pair<int,int> b)
{
	if(a.second < b.second)
		return true;
	else
		return false;
}
class person
{
public:
	int start;
	int during;
	int vip;
};
bool operator<(person a,person b)
{
	return a.start > b.start;
}
class table
{
public:
	int count;
	int vip;
	int remain;
};
int time2int(string t)
{
	int h,m,s;
	h = (t[0] - '0') * 10 + t[1] - '0';
	m = (t[3] - '0') * 10 + t[4] - '0';
	s = (t[6] - '0') * 10 + t[7] - '0';
	return (h - 8) * 3600 + m * 60 + s;
}
string int2time(int t)
{
	int h = t / 3600;
	int m = (t - h * 3600) / 60;
	int s = t - h * 3600 - m * 60;
	h += 8;
	string ret("00:00:00");
	ret[0] = (h / 10) + '0';
	ret[1] = (h % 10) + '0';
	ret[3] = (m / 10) + '0';
	ret[4] = (m % 10) + '0';
	ret[6] = (s / 10) + '0';
	ret[7] = (s % 10) + '0';
	return ret;
}
int getminute(int a,int b)
{
	int ret = (b - a) / 60;
	if((b - a) % 60 >= 30)
		++ ret;
	return ret;
}
int main()
{
	int n;
	cin >> n;
	priority_queue<person> people;
	for(int i = 0;i < n;++ i)
	{
		string t;
		cin >> t;
		int d;
		cin >> d;
		int v;
		cin >> v;
		person tmp;
		tmp.start = time2int(t);
		tmp.during = d * 60;
		if(tmp.during > 7200)
			tmp.during = 7200;
		tmp.vip = v;
		people.push(tmp);
	}
	int k,m;
	cin >> k >> m;
	vector<table> tables(k);
	for(int i = 0;i < k;++ i)
	{
		tables[i].count = 0;
		tables[i].remain = 0;
		tables[i].vip = 0;
	}
	for(int i = 0;i < m;++ i)
	{
		int tmp;
		cin >> tmp;
		tables[tmp - 1].vip = 1;
	}
	vector< pair<int,int> > result;
	int now(0);
	list<person> cur;
	int number_of_vip_in_cur(0);
	while(now < (21 - 8) * 3600 && !(people.empty() && cur.empty()))
	{
		while(!people.empty() && people.top().start <= now)
		{
			if(people.top().vip == 1)
				++ number_of_vip_in_cur;
			cur.push_back(people.top());
			people.pop();
		}
		if(cur.empty())
		{
			if(!people.empty())
			{
				int past = now;
				now = people.top().start;
				for(int i = 0;i < k;++ i)
				{
					tables[i].remain -= (now - past);
					if(tables[i].remain <= 0)
						tables[i].remain = 0;
				}
				continue;
			}
		}

		for(int i = 0;i < k;++ i)            //先处理VIP桌子和VIP人
		{
			if(!cur.empty())
			{
				if(tables[i].remain == 0 && tables[i].vip == 1)		//有空的VIP桌
				{
					list<person>::iterator it;
					for(it = cur.begin();it != cur.end();++ it)
						if(it->vip == 1)
							break;
					if(it != cur.end())								//队列中有VIP
					{
						tables[i].remain = it->during;
						++ tables[i].count;
						result.push_back(make_pair(it->start,now));
						cur.erase(it);
					}
				}
			}
			else
				break;

		}
		for(int i = 0;i < k;++ i)
		{
			if(!cur.empty())	//如果当前队列中有人
			{
				if(tables[i].remain == 0)
				{
					tables[i].remain = cur.front().during;
					++ tables[i].count;
					result.push_back(make_pair(cur.front().start,now));
					cur.pop_front();
				}
			}
			else
				break;
		}


		int min(INFINITY);
		for(int i = 0;i < k;++ i)
			if(tables[i].remain < min)
				min = tables[i].remain;
		now += min;
		for(int i = 0;i < k;++ i)
		{
			tables[i].remain -= min;
		}
	}
	sort(result.begin(),result.end(),comp);
	for(size_t i = 0;i < result.size();++ i)
	{
		string a = int2time(result[i].first);
		string b = int2time(result[i].second);
		int minutes = getminute(result[i].first,result[i].second);
		cout << a << " " << b << " " << minutes << endl;
	}
	for(int i = 0;i < k;++ i)
	{
		cout << tables[i].count;
		if(i != k - 1)
			cout << " ";
	}
	return 0;
	
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
The following is the data that you can add to your input file (as an example). Notice that the first line is going to be a line representing your own hobbies. In my case, it is the Vitaly,table tennis,chess,hacking line. Your goal is to create a class called Student. Every Student will contain a name (String) and an ArrayList<String> storing hobbies. Then, you will add all those students from the file into an ArrayList<Student>, with each Student having a separate name and ArrayList of hobbies. Here is an example file containing students (the first line will always represent yourself). NOTE: eventually, we will have a different file containing all our real names and hobbies so that we could find out with how many people each of us share the same hobby. Vitaly,table tennis,chess,hacking Sean,cooking,guitar,rainbow six Nolan,gym,piano,reading,video games Jack,cooking,swimming,music Ray,piano,video games,volleyball Emily,crochet,drawing,gardening,tuba,violin Hudson,anime,video games,trumpet Matt,piano,Reading,video games,traveling Alex,swimming,video games,saxophone Roman,piano,dancing,art Teddy,chess,lifting,swimming Sarah,baking,reading,singing,theatre Maya,violin,knitting,reading,billiards Amy,art,gaming,guitar,table tennis Daniel,video games,tennis,soccer,biking,trumpet Derek,cooking,flute,gaming,swimming,table tennis Daisey,video games,guitar,cleaning,drawing,animated shows,reading,shopping Lily,flute,ocarina,video games,baking Stella,roller skating,sudoku,watching baseball,harp Sophie,viola,ukulele,piano,video games
06-10

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值