Ahui Writes Word(01转化为多重背包)

Ahui Writes Word

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1235 Accepted Submission(s): 465


Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)

Output
Output the maximum value in a single line for each test case.

Sample Input
  
  
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5

Sample Output
  
  
15
Hint
Input data is huge,please use “scanf(“%s”,s)”

Author
Ahui

Source

要点: 由于N*V=10^9  数据量很大,用01背包解决肯定会超时。可是看看 w、c 的范围,0 ≤ Vi , Ci ≤ 10,重复的很多,可以转换为多重背包利用二进制优化。
#include <stdio.h>
#include <string.h>
#define maxn 10050 
#define MAX 100050 
int f[maxn];
int c[MAX],val[MAX],num[15][15]; 
int N,V; 
int max(int x,int y)
{
	return x>y?x:y;	
} 
void ZeroOnepace(int cost,int value)
{
	int i;
	for(i=V;i>=cost;i--)
		f[i]=max(f[i],f[i-cost]+value);	
} 
void multipace(int cost,int value,int amount)
{
	int i,k;
	k=1;
	while(k<amount)
	{
		ZeroOnepace(cost*k,value*k);
		amount-=k;
		k*=2;	
	}	
	ZeroOnepace(cost*amount,value*amount);
} 
int main()
{
	char name[100]; 
	int i,j; 
	while(scanf("%d%d",&N,&V)==2)
	{
		memset(num,0,sizeof(num)); 
		for(i=1;i<=N;i++)
		{
			scanf("%s",name);
			scanf("%d%d",&val[i],&c[i]);
			num[c[i]][val[i]]++;	
		}	
		memset(f,0,sizeof(f)); 
		for(i=0;i<=10;i++) 
			for(j=0;j<=10;j++) 
				if(num[i][j]!=0) 
					multipace(i,j,num[i][j]);
		printf("%d\n",f[V]); 
	}	
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值