(DP,多重背包) Ahui Writes Word -- HDOJ

Ahui Writes Word
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 948 Accepted Submission(s): 288

Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)

Output
Output the maximum value in a single line for each test case.

Sample Input

5 20
go 5 8
think 3 7
big 7 4
read 2 6
write 3 5

Sample Output

15
Hint

Input data is huge,please use “scanf(“%s”,s)”

Author
Ahui

Source
ACMDIY第二届群赛

Recommend
notonlysuccess

总结:
在知道了是多重背包之后,WA了N+次,今天上午做了一个多重背包的问题,刚刚做的时候就回忆着多重背包的算法做的,漏洞百出。。最后还是一点一点的比较代码,找到错误的。

题目的数据量比较大,但是每个单词的价值和复杂度取值范围都很小,所以重复的必然有很多,这也就转化成了多重背包问题

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main(void)
{
 //   freopen("in.txt","r",stdin);
    int n,W;
    while(scanf("%d %d",&n,&W) != EOF)
    {
        int v[1005],w[1005],num[15][15],cnt=0;
        char c[13];
        memset(num,0,sizeof(num));
        int flag = 0;
        for(int i=0; i<n; ++i)
        {
            int val,we;
            scanf("%s %d %d",c,&val,&we);

            if(num[val][we] == 0)
            {
                if(!val && !we && flag)
                {
                    num[val][we] += 1;
                    continue;
                }
                if(!val && !we) flag = 1;
                v[cnt] = val;
                w[cnt++] = we;
            }
            num[val][we] += 1;
        }

     //   cout << cnt <<endl;
        int dp[100005];
        memset(dp,0,sizeof(dp));
        for(int i=0; i<cnt; ++i)
        {
            if(num[v[i]][w[i]]*w[i] >= W)
            {
                for(int j=w[i]; j<=W; ++j)
                        dp[j] = max(dp[j],dp[j-w[i]] + v[i]);
            }
            else
            {
                int k=1;
                while(k < num[v[i]][w[i]])
                {
                    for(int j=W; j>=w[i]*k; --j)
                        dp[j] = max(dp[j],dp[j-w[i]*k] + k*v[i]);
                    num[v[i]][w[i]] -= k;
                    k *= 2;
                }
                for(int j=W; j>=w[i]*num[v[i]][w[i]]; --j)
                        dp[j] = max(dp[j],dp[j-w[i]*num[v[i]][w[i]]] + num[v[i]][w[i]]*v[i]);
            }
        }

        cout << dp[W] <<endl;


    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值