POJ2492--A Bug's Life--并查集

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
/*
此题和1703两个帮派其实本质上是相同的
给出两个数字,a和b.
如果a或者b还没有敌对(异性)那么就设置异性。
然后是重点,注意,每给出a和b先判是否同个祖先,如果已经是了,
接下来就不用操作了。否则可能出现死循环什么的
*/
#include <iostream>
#include <cstdio>
using namespace std;
int father[2008];
int rank1[2008];
int didui[2008];
int find(int x)
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
void Union(int a,int b)
{
	int aa=find(a);
	int bb=find(b);
	if(rank1[aa]>rank1[bb])
	{
		father[bb]=aa;
	}
	else if(rank1[aa]==rank1[bb])
	{
		father[bb]=aa;
		rank1[aa]++;
	}
	else 
	{
		father[aa]=bb;
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		bool flag=true;
		int m,n;
		scanf("%d%d",&n,&m);//n只臭虫,m次交配
		memset(rank1,0,sizeof(rank1));
		memset(didui,0,sizeof(didui));
		for(int j=1;j<=n;j++)
		{
			father[j]=j;
		}
		int u,v;
		for(int j=1;j<=m;j++)
		{
			scanf("%d%d",&u,&v);
			if(!flag)continue;
			if(!didui[u])
			{
				didui[u]=v;
			}
			if(!didui[v])
			{
				didui[v]=u;
			}
			if(find(u)==find(v))
			{
				flag=false;
			}
			else
			{
				Union(u,didui[find(v)]);
				Union(v,didui[find(u)]);
			}
		}
		printf("Scenario #%d:\n",i);
		if(flag)printf("No suspicious bugs found!\n");
		else printf("Suspicious bugs found!\n");
		if(i!=t)printf("\n");
	}
	return 0;
}

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 2008
int father[maxn];
int didui[maxn];
int n,m;
void init()
{
	for(int i=1;i<=n;i++)
	{
		father[i]=i;
	}
}
int find(int x)
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
void Union(int a,int b)
{
	int aa=find(a);
	int bb=find(b);
	father[aa]=bb;
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		memset(didui,0,sizeof(didui));
		bool flag=false;
		scanf("%d%d",&n,&m);
		init();
		for(int j=1;j<=m;j++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			if(flag)continue;
			if(find(u)==find(v))
			{
				flag=true;//找到同性恋了
			}
			else
			{
				if(!didui[find(u)])didui[find(u)]=v;
				if(!didui[find(v)])didui[find(v)]=u;
				Union(v,didui[find(u)]);
				Union(u,didui[find(v)]);
			}
		}
		printf("Scenario #%d:\n",i);
		if(flag)printf("Suspicious bugs found!\n");
		else printf("No suspicious bugs found!\n");
	}
	return 0;
}


 


                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值