POJ3277--City Horizon

Description

Farmer John has taken his cows on a trip to the city! As the sun sets, the cows gaze at the city horizon and observe the beautiful silhouettes formed by the rectangular buildings.

The entire horizon is represented by a number line with N (1 ≤ N ≤ 40,000) buildings. Building i's silhouette has a base that spans locations Ai through Bi along the horizon (1 ≤ Ai < Bi ≤ 1,000,000,000) and has height Hi (1 ≤ Hi ≤ 1,000,000,000). Determine the area, in square units, of the aggregate silhouette formed by all N buildings.

Input

Line 1: A single integer: N
Lines 2.. N+1: Input line i+1 describes building i with three space-separated integers: Ai, Bi, and Hi

Output

Line 1: The total area, in square units, of the silhouettes formed by all N buildings

Sample Input

4
2 5 1
9 10 4
6 8 2
4 6 3

Sample Output

16

/*
求矩形面积并
X轴离散化。Y轴扫描
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
#define maxn 40008
#define lson 2*id,l,mid
#define rson 2*id+1,mid,r
long long int X[2*maxn];
long long int coll[2*maxn];
int kx;
long long int binary_search(long long int a)
{
	int l=1,r=kx-1;
	while(l<r)
	{
		int mid=(l+r)>>1;
		if(X[mid]>=a)
		{
			r=mid;
		}
		else l=mid+1;
	}
	return l;
}
struct Line
{
	int x1,x2,y;
	bool vis;//用来标记是上边还是下边
}line[2*maxn];
bool cmp(Line a,Line b)
{
	return a.y<b.y;
}
struct ST
{
	int l,r,add;
	long long int len;
}st[8*maxn];
void buildtree(int id,int l,int r)
{
	st[id].l=l;
	st[id].r=r;
	if(l+1==r)
	{
		st[id].add=st[id].len=0;
		return;
	}
	int mid=(l+r)>>1;
	buildtree(lson);
	buildtree(rson);
	st[id].add=st[id].len=0;
}
void PushUp(int id)
{
	if(st[id].add >= 1) st[id].len=X[st[id].r] - X[st[id].l];
	else if(st[id].l+1 == st[id].r) st[id].len=0;
	else st[id].len=st[2*id].len+st[2*id+1].len;
}
void update(int id,int l,int r,int ope)
{
	if(st[id].l==l && st[id].r==r)
	{
		st[id].add+=ope;
		if(st[id].add>=1)
		{
			st[id].len=X[r]-X[l];
		}
		else if(l+1==r) st[id].len=0;
		else
		{
			st[id].len=st[2*id].len+st[2*id+1].len;
		}
		return;
	}
	if(st[2*id].r >= r)
	{
		update(2*id,l,r,ope);
		PushUp(id);
		return;
	}
	if(st[2*id+1].l <= l)
	{
		update(2*id+1,l,r,ope);
		PushUp(id);
		return;
	}
	update(2*id,l,st[2*id].r,ope);
	update(2*id+1,st[2*id+1].l,r,ope);
	PushUp(id);
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int x1,x2,y;
		int k=1;kx=1;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d%d",&x1,&x2,&y);
			X[kx++]=x1;
			X[kx++]=x2;
			line[k].x1=x1;
			line[k].x2=x2;
			line[k].y=0;
			line[k++].vis=1;
			line[k].x1=x1;
			line[k].x2=x2;
			line[k].y=y;
			line[k++].vis=0;
		}
		sort(line+1,line+k,cmp);
		sort(X+1,X+kx);
		buildtree(1,1,kx-1);//
		long long int ns=0;
		long long int lx=0,ly=0;
		for(int i=1;i<k;i++)
		{
			if(line[i].vis)
			{
				ns+=lx*(line[i].y-ly);
				update(1,binary_search(line[i].x1),binary_search(line[i].x2),1);
				lx=st[1].len;
				ly=line[i].y;
			}
			else
			{
				ns+=lx*(line[i].y-ly);
				update(1,binary_search(line[i].x1),binary_search(line[i].x2),-1);
				lx=st[1].len;
				ly=line[i].y;
			}
		}
		printf("%lld\n",ns);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值