POJ2002 Squares

Squares

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 < = n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4

1 0

0 1

1 1

0 0

9

0 0

1 0

2 0

0 2

1 2

2 2

0 1

1 1

2 1

4

-2 5

3 7

0 0

5 2

0

Sample Output

1

6

1

给出n个整点,求正方形的个数n的范围是1000,所以n*n左右的算法于是乎,枚举两个点,检测另外两个点是否在检测呢就用hash

#include <iostream>
#include <cstdio>
#include <cstring>
#define MOD 4209207
#define N 1010
#define M 20000
using namespace std;

struct CHash
{
    int m_nX;
    int m_nY;
    bool m_bExi;
} nhash[MOD];

inline int hash(int x,int y)
{
    int k = x * M + y;
    int p = (k<0?-k:k) % MOD;
    while( nhash[ p ].m_bExi && ( nhash[ p ].m_nX != x || nhash[ p ].m_nY != y ) )
    {
        p ++;
        if( p >= MOD ) p %= MOD;
    }
    return p;
}
int x[N],y[N];
int main()
{
    int n,tx,ty,dx,dy,cx,cy;
    while(scanf("%d",&n)==1&&n)
    {
        int ans = 0;
        memset(nhash,0,sizeof(nhash));
        for(int i = 0 ; i < n ; i++ )
        {
            scanf("%d %d",x+i,y+i);
            int k = hash(x[i],y[i]);
            nhash[ k ].m_nX = x[i];
            nhash[ k ].m_nY = y[i];
            nhash[ k ].m_bExi = true;
        }
        for(int i = 0 ; i < n ; i++ )
        {
            //这里呢,另有一番说法...以下摘自poj discuss里
            /*******************
            我开始用的公式是
            x3=x1+(y1-y2);y3=y1-(x1-x2); x4=x2+(y1-y2);y4=y2-(x1-x2)
            和你同样的处理方法(j从i+1到n循环),最后就WA

            经我仔细研究发现:
            其实对于这个公式求的正方形只能是P1P2P4P3形状的
            这样如果用第一种处理方式,就很可能处理掉很多正方形,其实任何给定的P1P2,本应该能为某个正方形贡献一次重复,那么四条边的话就重复四次,最后就除以4
            但是我们输入的P1P2的顺序可能使我们得不到一次重复 我们误以为顺序和反过来一样 就对半分 除以2 其实是错的
            如果我们把题意总第一组测试实例4个点的顺序改变一下再输入,先不要除 你会发现得到的的正方形的个数是不固定的 这就是由于输入的顺序照成的

            那么第二种处理方式(就是j从0到n循环)正好弥补了这个错误
            *********************************/
            for(int j = 0 ; j < n ; j++ )
            {
                if(i==j)continue;
                tx = x[ j ] - x[ i ];
                ty = y[ j ] - y[ i ];
                cx = x[ i ] + ty;
                cy = y[ i ] - tx;
                dx = x[ j ] + ty;
                dy = y[ j ] - tx;
                if( nhash[ hash(cx,cy) ].m_bExi && nhash[ hash(dx,dy) ].m_bExi )
                {
                    ans++;
                }
            }
        }
        printf("%d\n",ans>>2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值