【PAT】A1036 Boys vs Girls【最大/最小值】

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​ −grade​M
​​ . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

题意

一二行分别输出女生成绩最高男生成绩最低的两名同学 (如有不存在则输出Absent),最后一行输出他们成绩的差(如果有一个不存在则为NA)

思路

遍历一遍即可。
写的时候想复杂了,排序然后把首位两个人取出,这样复杂度高些但是这道题简单,也通过了。

代码

#include <iostream>
#include <algorithm>
#define maxN 1001
using namespace std;
struct Student{
    char name[11];
    char gender;
    char id[11];
    int grade;
}stu[maxN];
bool cmp(Student s1, Student s2){
    return s1.gender != s2.gender ? s1.gender < s2.gender : s1.grade > s2.grade;
}
int main() {
    int N;
    scanf("%d", &N);
    for(int i = 0; i < N; ++i){
        scanf("%s %c %s %d", stu[i].name, &stu[i].gender, stu[i].id, &stu[i].grade);
    }
    sort(stu, stu + N, cmp);
    // flag1,flag2分别代表是否存在
    bool flag1 = stu[0].gender == 'F', flag2 = stu[N - 1].gender == 'M';
    if(flag1){
        printf("%s %s\n", stu[0].name, stu[0].id);
    }else{
        printf("Absent\n");
    }
    if(flag2){
        printf("%s %s\n", stu[N - 1].name, stu[N - 1].id);
    }else{
        printf("Absent\n");
    }
    if(flag1 && flag2){
        printf("%d", stu[0].grade - stu[N - 1].grade);
    }else{
        printf("NA");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值