【PAT】A1075 PAT Judge【排序】

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10^​4​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10^​5
​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

思路

题目本身不难,就是将考生按总成绩排名。主要是细节比较多:

  • 编译错误的提交分数为-1,但是最终输出为0,而未提交最终输出为“-”,所以我们需要用-2代表未提交以区分这两种情况。
  • 为了方便,我们读入的时候只更新各项成绩,读取完再去遍历计算每个考生的总成绩和完美提交数(先算出来后面排序的时候方便,也减少重复计算)。

我通过将用户的下标存储在pq中然后交换pq,以使得排序的速度比较快。另外虽然字段比较多但是我还是使用了数组,虽然变量上乱了些,但是后面的代码省去了很多obj.这种语法,反而简洁。主要是初始化数据的时候很方便。

关于排名问题,我们可以逆向思考,什么时候排名需要更新,当当前的考试分数和上一位不同的时候,就更新成当前考生的序号(从1开始),否则就跟上一位一样,也就是不更新。

代码

#include <cstdio>
#include <algorithm>
#define MAX_K 6
#define MAX_N 10001
using namespace std;
int scores[MAX_N][MAX_K], perfect[MAX_N], total[MAX_N], totalScore[MAX_N], pq[MAX_N], show[MAX_N];
bool cmp(int p, int q){
    if(total[p] != total[q]){
        return total[p] > total[q];
    }else if(perfect[p] != perfect[q]){
        return perfect[p] > perfect[q];
    }else{
        return p < q;
    }
}
int main() {
    // 初始化,用-2代表没有提交过
    fill(scores[0], scores[0] + MAX_N * MAX_K, -2);
    fill(show, show + MAX_N, false);
    
    // 读入每题的满分
    int N, K, M;
    scanf("%d %d %d", &N, &K, &M);
    for(int i = 1; i <= K; i++){
        scanf("%d", &totalScore[i]);
    }
    
    // 读入所有提交,所有成绩取最高的一次
    for(int i = 0, userId, problemId, score; i < M; i++){
        scanf("%d %d %d", &userId, &problemId, &score);
        scores[userId][problemId] = max(scores[userId][problemId], score);
    }
    
    
    for(int i = 1, sum; i <= N; i++){
        pq[i] = i;// 将用户加入队列
        
        // 计算该用户的总成绩
        sum = 0;
        for(int j = 1, s; j <= K; j++){
            s = scores[i][j];
            if(s < 0) continue;// 过滤掉编译错误和未提交成绩
            sum += s;
            show[i] = true; // 有一个成绩则要输出当前的用户
            if(s == totalScore[j]){
                perfect[i]++;
            }
        }
        
        total[i] = sum;// 赋值
    }
    
    // 根据总分(不升) > 完美提交题数(不升) > 用户id(升序)的优先级排序
    sort(pq + 1, pq + N + 1, cmp);
    
    // 输出
    for(int i = 1, r = 1; i <= N; i++){
        if(!show[pq[i]]) continue;// 过滤掉无成绩的用户
        if(total[pq[i]] != total[pq[i - 1]]) r = i;// 计算排名
        printf("%d %05d %d", r, pq[i], total[pq[i]]);
        for(int j = 1; j <= K; j++){
            if(scores[pq[i]][j] == -2){// 将未提交处理成“-”符号
                printf(" -");
            }else{
                printf(" %d", max(scores[pq[i]][j], 0));
            }
        }
        putchar('\n');
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值