[PAT A1075]PAT Judge

[PAT A1075]PAT Judge

题目描述

1075 PAT Judge (25 分)The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

输入格式

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:
user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

输出格式

For each test case, you are supposed to output the ranklist in the following format:
rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

输入样例

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

输出样例

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

解析

  1. 题目的意思就是首先输入n,k,m三个数,n表示学生的总数,k表示总共有多少道题,m表示有多少次提交记录;然后输入k个数,分别表示每个题目的总分是多少;接下来输入m行,每行是一个提交记录,分为三个数,第一个数是提交的学生的id,第二个数是提交的题目的序号,第三个数是该题的得分。
  2. 输出格式就是输出学生的排名,id,还有他们每题的分数,注意,这里如果有一题没有提交过,那么就输出-,如果有两个学生成绩相同,那么按照他们完美解决的题目数(也就是他们做的得了满分题的个数)排序,如果还相同,则按照学号从低到高排序。这里如果一个人没有交过一次,或者交的数据都是不能编译通过的,那么他的数据将不会被输出
  3. 然后这个题目我写了两遍都有两个数据过不了测试,后面才发现,如果一个人交的是0分,那说明他的成绩是有效的,是编译通过了的,只不过答案不对,那么这个人的成绩还是需要输出的。(巨坑,大家一定要注意这个地方!)
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct student
{
 bool ok = false; //判断他的成该不该被输出
 int id, solved = 0, sum = 0, rank; //分别是id,完美解决题目数,总分和排名
 int score[6] = { -1,-1,-1,-1,-1,-1 };
};
bool cmp(student s1, student s2) {
 if (s1.sum != s2.sum) return s1.sum > s2.sum;
 if (s1.solved != s2.solved) return s1.solved > s2.solved;
 else return s1.id < s2.id;
}
int full[6];  //用于存储每道题目的满分是多少
int main()
{
 int N, K, M;
 cin >> N >> K >> M;
 vector<student>stu(N+10);
 for (int i = 1; i <= N; i++) stu[i].id = i;
 for (int i = 1; i <= K; i++) scanf("%d", &full[i]);
 for (int i = 0; i < M; i++) {
  int id, x, x_num;
  scanf("%d%d%d", &id, &x, &x_num);
  if (x_num == -1) {
   if (stu[id].score[x] == -1) stu[id].score[x] = 0;
  }
  else {
   if (x_num > stu[id].score[x]) {
    stu[id].score[x] = x_num;
    stu[id].ok = true;
   }
  }
 }
 for (int i = 1; i <= N; i++) {
  for (int j = 1; j <= K; j++) {
   if (stu[i].score[j] == full[j]) stu[i].solved++;
   if (stu[i].score[j] != -1) stu[i].sum += stu[i].score[j];
  }
 }
 sort(stu.begin() + 1, stu.begin() + 1 + N, cmp);
 stu[1].rank = 1;
 for (int i = 1; i < N; i++) {
  if (stu[i + 1].sum == stu[i].sum) stu[i + 1].rank = stu[i].rank;
  else stu[i + 1].rank = i + 1;
 }
 for (int i = 1; i <= N; i++) {
  if (stu[i].ok==false) continue;
  printf("%d %05d %d ", stu[i].rank, stu[i].id, stu[i].sum);
  for (int j = 1; j <= K; j++) {
   if (stu[i].score[j] == -1) printf("-");
   else printf("%d", stu[i].score[j]);
   if (j != K) printf(" ");
  }
  printf("\n");
 }
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值