【PAT】A1149 Dangerous Goods Packaging【散列】

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10^​4​​ ), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] … G[K]

where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

题意

给出若干对会发生化学反应的化学品。然后给出若干组化学品,问每组化学品是否会爆炸。

思路

对每个化学品存储与之会发生反应的化学品,对一组化学品,遍历一个化学品时:

  • 该化学品的标记是否为true,是则会发生爆炸。
  • 将与它会发生反应的化学品标记为true,

代码

#include <cstdio>
#include <map>
#include <vector>
#include <cstring>
#include <algorithm>
#define MAX_N 20000
#define MAX_K 1000
using namespace std;
int list[MAX_K];
map<int, int> ids;
int cnt = 0;
int getIndex(int n){
    if(ids.find(n) == ids.cend()){
        ids[n] = cnt++;
    }
    return ids[n];
}
vector<int> pairs[MAX_N];// 记录每个化学品不能同时存放的其他化学品
bool marked[MAX_N];
bool check(int K){
    fill(marked, marked + (int)ids.size(), false);
    
    for(int i = 0; i < K; i++){
        if(marked[list[i]]) return false;// 发现了一个不能同时存在的化学品,返回false
        for(int v : pairs[list[i]]){// 将当前遍历到的化学品不能同时存放的化学品标记为true
            marked[v] = true;
        }
    }
    return true;
}
int main() {
    
    int N, M;
    scanf("%d %d", &N, &M);
    for(int i = 0, u, v; i < N; i++){
        scanf("%d %d", &u, &v);
        u = getIndex(u);
        v = getIndex(v);
        pairs[u].push_back(v);
        pairs[v].push_back(u);
    }
    
    for(int i = 0, K; i < M; i++){
        scanf("%d", &K);
        for(int j = 0, t; j < K; j++){
            scanf("%d", &t);
            list[j] = getIndex(t);
        }
        printf(check(K) ? "Yes\n" : "No\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值