Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.
Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.
After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.
Output Specification:
For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.
If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.
The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.
Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0
题意
一个人要向另一个人表白,如果他们是异性,那么这个人会先找一个同性中间人,这个同性中间人再找另一个表白目标的同性中间人,最后这个中间人找到表白目标。
如果是同性,那么中间就经过两个同性中间人。
思路
存储每个人的朋友。然后二重遍历表白者和被表白者的朋友,他们的朋友之间又是朋友的,则成为一组答案。条件是朋友不能是目标,然后还要注意性别。
这题恶心在0000和-0000是代表不同的性别,所以读入的时候不能将其作为实型来读,不然就区分不开。
代码
#include <cstdio>
#include <vector>
#include <algorithm>
#define MAX_CODE 10000
using namespace std;
typedef pair<int, int> Item;
bool gender[MAX_CODE];
vector<int> friends[MAX_CODE];
bool isFriend(int m, int n){
for(int f : friends[m]){
if(f == n) return true;
}
return false;
}
void solve(int src, int dst){
if(src < 0) src = -src;
if(dst < 0) dst = -dst;
if(friends[src].empty() || friends[dst].empty()){
printf("0\n");
return;
}
vector<Item> res;
sort(friends[src].begin(), friends[src].end());
sort(friends[dst].begin(), friends[dst].end());
bool srcG = gender[src], dstG = gender[dst];
for(int f1 : friends[src]){
if(gender[f1] != srcG || f1 == dst) continue;
for(int f2 : friends[dst]){
if(gender[f2] != dstG || f2 == src) continue;
if(isFriend(f1, f2)){
res.push_back(Item(f1, f2));
}
}
}
printf("%d\n", (int)res.size());
for(int i = 0; i < res.size(); i++){
printf("%04d %04d\n", res[i].first, res[i].second);
}
}
int parse(char s[]){
bool isBoy = s[0] !='-';
int id = 0;
for(int i = isBoy ? 0 : 1; s[i] != '\0'; i++){
id = id * 10 + (s[i] - '0');
}
gender[id] = isBoy;
return id;
}
int main() {
fill(gender, gender + MAX_CODE, true);
int N, M;
scanf("%d %d", &N, &M);
getchar();
char s1[6], s2[6];
for(int i = 0, u, v; i < M; i++){
scanf("%s %s", s1, s2);
u = parse(s1);
v = parse(s2);
friends[u].push_back(v);
friends[v].push_back(u);
}
int K;
scanf("%d", &K);
for(int i = 0, src, dst; i < K; i++){
scanf("%d %d", &src, &dst);
solve(src, dst);
}
return 0;
}