【floyd算法】UVA821 Page Hopping

Given a graph in which all nodes can be
reached from any starting point, your job is to
find the average shortest path length between arbitrary pairs of nodes. For example, consider the
following graph. Note that links are shown as directed edges, since a link from page a to page b
does not imply a link from page b to page a.
The length of the shortest path from node 1
to nodes 2, 3, and 4 is 1,1, and 2 respectively. From node 2 to nodes 1, 3 and 4, the shortest paths
have lengths of 3, 2, and 1. From node 3 to nodes 1, 2, and 4, the shortest paths have lengths of 1, 2,
and 3. Finally, from node 4 to nodes 1, 2, and 3 the shortest paths have lengths of 2, 3, and 1. The
sum of these path lengths is 1 + 1 + 2 + 3 + 2 + 1 + 1 + 2 + 3 + 2 + 3 + 1 = 22. Since there are
12 possible pairs of nodes to consider, we obtain an average path length of 22/12, or 1.833 (accurate
to three fractional digits).

Input

The input data will contain multiple test cases. Each test case will consist of an arbitrary number of
pairs of integers, a and b, each representing a link from a page numbered a to a page numbered b. Page
numbers will always be in the range 1 to 100. The input for each test case will be terminated with a
pair of zeroes, which are not to be treated as page numbers. An additional pair of zeroes will follow
the last test case, effectively representing a test case with no links, which is not to be processed. The
graph will not include self-referential links (that is, there will be no direct link from a node to itself),
and at least one path will exist from each node in the graph to every other node in the graph.

Output

For each test case, determine the average shortest path length between every pair of nodes, accurate to
three fractional digits. Display this length and the test case identifier (theyre numbered sequentially
starting with 1) in a form similar to that shown in the sample output below.

Sample Input

1 2 2 4 1 3 3 1 4 3 0 0
1 2 1 4 4 2 2 7 7 1 0 0
0 0

Sample Output

Case 1: average length between pages = 1.833 clicks
Case 2: average length between pages = 1.750 clicks

题意

给出多组数据,一组一行,每组数据有若干对点,一对点代表相互之间直接连接(即距离为1),每组数据使用0 0结束。最后一个0 0 表示结束所以数据的输入。求每组数据中,任意两个点之间的平均距离。

思路

参考了大佬的博客,原文链接。又学了一招输入处理的奇淫巧技。使用floyd算法算出距离,然后统计有效的距离和个数即可。

代码

#include <cstdio>
#include <climits>
#include <cmath>
#include <algorithm>
#define MAX_N 101
#define oo 10000000
using namespace std;
int d[MAX_N][MAX_N];
int main() {
    int a, b, n = 0, cases = 0;
    while (~scanf("%d %d", &a, &b) && a + b) {
        // 初始化
        for(int i = 1; i < MAX_N; i++){
            for(int j = i + 1; j < MAX_N; j++){
                d[i][j] = d[j][i] = oo;
            }
            d[i][i] = 0;
        }
        
        // 读取的同时更新出现的最大顶点n
        do{
            d[a][b] = 1;
            n = max(n, max(a, b));
        }while(~scanf("%d %d", &a, &b) && a + b);
        
        // floyd,只需要更新到n即可
        for(int k = 1; k <= n; k++){
            for(int i = 1; i <= n; i++){
                for(int j = 1; j <= n; j++){
                    d[i][j] = min(d[i][j], d[i][k] + d[k][j]);
                }
            }
        }
        
        // 计算总距离和有效距离个数
        int count = 0, total = 0;
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++){
                if(d[i][j] != oo && d[i][j] > 0){
                    total += d[i][j];
                    count++;
                }
            }
        }
        
        // 输出
        printf("Case %d: average length between pages = %.3f clicks\n", ++cases, (float)total / count);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值