【PAT】A1022 Digital Library【Map的使用】

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title — a string of no more than 80 characters;
Line #3: the author — a string of no more than 80 characters;
Line #4: the key words — each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher — a string of no more than 80 characters;
Line #6: the published year — a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year
Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print “Not Found” instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目大意

模拟查询功能。给出n本书的信息,以及m个查询的命令,数字标号对应查询的字段(书名、作者名…具体看原题的link #x),数字编号后面的字符串是查询的关键词,要求输出这行命令以及输出满足条件的书的id,如果一个都没有找到,输出Not Found。

思路

除了关键词有点特殊(多个关键词可能对应同一本书),而且对关键词的读取需要特殊处理(因为关键词用空格隔开,可能有一个或者多个)。其他的字段抽象上是完全一致的。所以我们建立一个map数组(即这个数组的每一个元素是一个map)来对应各个字段。每一个map的key是string,对应一个关键词,map的value是set<int>用来存储书的id。使用set而不是vector是为了让其自动排序(要求结果根据id升序输出),当然也可以使用vector,输出前先进行一次排序,再输出。
使用set平均124ms,而vector平均83ms,差别不大,使用vector稍微繁琐一些。

代码1(使用set)

#include <iostream>
#include <map>
#include <set>
#include <cstdio>
using namespace std;
#define K 6
// 创建map数组
map<string, set<int>> m[K];
int main(int argc, const char * argv[]) {
    int n;
    scanf("%d", &n);
    int id;
    string str;
    while (n-- > 0) {
        scanf("%d\n", &id);
        for(int i = 1; i < 6; i++){
            // 书的关键词可能有多个,需要特殊处理
            if(i == 3){
                while (cin >> str) {
                    m[i][str].insert(id);
                    // 使用一个getchar()来吸收关键词之间的空格或者行末的换行符
                    // 当读到\n时代表后面没有关键词了,跳出循环
                    if(getchar() == '\n'){
                        break;
                    }
                }
            }else{
                getline(cin, str);
                m[i][str].insert(id);
            }
        }
    }
    
    int q;
    scanf("%d", &q);
    while (q-- > 0) {
        int type;
        string key;
        scanf("%d: ", &type);
        getline(cin, key);
        
        // 根据查询的字段获取对应的map的引用
        map<string, set<int> > &mm = m[type];
        
        // 输出命令
        cout << type << ": " << key << "\n";
        
        // 输出书的id或者Not Found
        if(mm.find(key) != mm.end()) {
            for(auto it = mm[key].begin(); it != mm[key].end(); it++)
                printf("%07d\n", *it);
        } else{
            printf("Not Found\n");
        }
    }
    return 0;
}

代码2(使用vector)

#include <iostream>
#include <map>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace std;
#define K 6
// 创建map数组
map<string, vector<int>> m[K];
int main(int argc, const char * argv[]) {
    int n;
    scanf("%d", &n);
    int id;
    string str;
    while (n-- > 0) {
        scanf("%d\n", &id);
        for(int i = 1; i < 6; i++){
            // 书的关键词可能有多个,需要特殊处理
            if(i == 3){
                while (cin >> str) {
                    m[i][str].push_back(id);
                    // 使用一个getchar()来吸收关键词之间的空格或者行末的换行符
                    // 当读到\n时代表后面没有关键词了,跳出循环
                    if(getchar() == '\n'){
                        break;
                    }
                }
            }else{
                getline(cin, str);
                m[i][str].push_back(id);
            }
        }
    }
    
    int q;
    scanf("%d", &q);
    while (q-- > 0) {
        int type;
        string key;
        scanf("%d: ", &type);
        getline(cin, key);
        
        // 根据查询的字段获取对应的map的引用
        map<string, vector<int> > &mm = m[type];
        
        // 输出命令
        cout << type << ": " << key << "\n";
        
        // 输出书的id或者Not Found
        if(mm.find(key) != mm.end()) {
            // 输出前先进行排序
            vector<int> &res = mm[key];
            sort(res.begin(), res.end());
            for(auto it = res.begin(); it != res.end(); it++)
                printf("%07d\n", *it);
        } else{
            printf("Not Found\n");
        }
    }
    return 0;
}
  • 7
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值