PAT A1022 Digital Library

本文介绍了PAT(A1022DigitalLibrary)编程题目,该题目要求实现一个图书管理系统,根据读者的查询返回匹配的书籍ID。文章详细讲解了如何使用map数据结构进行高效查询,包括按书名、作者、关键词、出版社和出版年份等条件。通过示例输入和输出展示了查询过程,并提供了关键代码片段,如利用cin和getline函数处理关键词输入。
摘要由CSDN通过智能技术生成

记录一下这题看似复杂但写法简洁的题。

A1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
4
) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

分析:

  1. 方法是使用map进行映射,将查询映射到对应书的编号集合
    五个种类的查询方式分别映射一个集合
    map<string,set<int>> mpTitle,mpAuthor,mpKey,mpPub,mpYear;

  2. 关键字部分的处理
    不断输入 直到获得换行符 break

 while(cin>>key)
        {
            mpKey[key].insert(id);
            c=getchar();
            if(c=='\n') break;
        }

转载:

cin 
遇到空格/回车终止,适合读取不含有空格的一串字符;
不舍弃空格、回车,也就是说需要一个getchar来吸收
getchar()
读取一个字符,包括空格/回车;可以用来取出换行符;
getline(cin,s)//只适用于string类
读取一串字符,可以包含空格,遇“回车”终止,且自动舍弃“回车”;
gets(m)//m是 char[]类型 
读取一串字符,可以包含空格,遇“回车”终止,且自动舍弃“回车”;
PAT是不支持的
cin.getline(m,6)
读取一串字符,可以包含空格,遇“回车”终止,且自动舍弃“回车”;
但是长度是有限制的,只能读取 "6"位,且最后一位是'\0'
  1. query模块单独拿出来
    void query(map<string,set> &mp,string &str)
    使用引用,防止超时

代码

#include<bits/stdc++.h>
using namespace std;

map<string,set<int>> mpTitle,mpAuthor,mpKey,mpPub,mpYear;

void query(map<string,set<int>> &mp,string &str) //mp中查找str 加引用是为了更快,否则会超时
{
    if(mp.find(str)!=mp.end())
    {
        for(set<int>::iterator it=mp[str].begin();it!=mp[str].end();it++)
        {
            printf("%07d\n",*it);
        }

    }
    else printf("Not Found\n");

}


int main()
{
    int n,m,id,type;
    scanf("%d",&n);
    string title,author,key,pub,year;

    for(int i=0;i<n;i++)
    {
        scanf("%d",&id);
        char c=getchar();
        getline(cin,title);
        mpTitle[title].insert(id);
        getline(cin,author);
        mpAuthor[author].insert(id);

        while(cin>>key)
        {
            mpKey[key].insert(id);
            c=getchar();
            if(c=='\n') break;
        }

        getline(cin,pub);
        mpPub[pub].insert(id);
        getline(cin,year);
        mpYear[year].insert(id);

    }

    scanf("%d",&m);
    string temp;
    for(int i=0;i<m;i++)
    {
        scanf("%d: ",&type);
        getline(cin,temp);

        cout<<type<<": "<<temp<<endl;
        if(type==1) query(mpTitle,temp);
        else if(type==2) query(mpAuthor,temp);
        else if(type==3) query(mpKey,temp);
        else if(type==4) query(mpPub,temp);
        else query(mpYear,temp);
    }
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值