【PAT】A1092 To Buy or Not to Buy【散列】

该博客介绍了PAT(A1092)编程题目,内容涉及如何判断商店的珠子是否能组成顾客所需的手串,并计算多余的或缺少的珠子数量。给出了输入输出规范和示例。
摘要由CSDN通过智能技术生成

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题意

给出商店的手串和顾客需要的手串。若可以将商店的手串制作成顾客需要的手串,则输出“Yes”,并输出剩余珠子的个数。否则输出“No”,并输出缺少的珠子个数。

思路

这题基本上是在A1084的基础上,将布尔数组换成int型数组进行计数即可。注意这里剩余个数和缺少个数要分开计数,因为珠子是不可替代的,如果多余了N个,缺少M个(M>0)。那么还是无法定制客户的手串。

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cctype>
using namespace std;
#define L 256
int main() {
    int cnt[L];
    fill(cnt, cnt + L, 0);
    char needStr[1001], storeStr[1001];
    scanf("%s%s", storeStr, needStr);
    // 遍历商店手串
    for(int i = 0, l = (int)strlen(storeStr); i < l; i++){
        cnt[storeStr[i]]++;
    }
    
    // 遍历想要的手串
    for(int i = 0, l = (int)strlen(needStr); i < l; i++){
        cnt[needStr[i]]--;
    }
    
    int remainCnt = 0;
    int lackCnt = 0;
    for(int i = 0; i < L; i++){
        if(cnt[i] < 0){
            lackCnt -= cnt[i];
        }else if(cnt[i] > 0){
            remainCnt += cnt[i];
        }
    }
    if(lackCnt > 0){
        printf("No %d", lackCnt);
    }else{
        printf("Yes %d", remainCnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值