【PAT甲级】1092 To Buy or Not to Buy(散列)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题目大意

这题就是给出两串珠子,第一串是卖的珠子,第二串是我需要的珠子,如果卖的珠子够,则输出多余了多少珠子;如果卖的珠子不够,则输出还差多少珠子。

个人思路

这题是乙级的1039,也是散列算法的应用。

设立一个计数数组,映射所有ascii码的字符的计数。然后逐个比较看是多了还是少了,再计算出来即可。

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long

const int maxn = 200;

using namespace std;

int main() {
    // 初始化
    int want[maxn] = {0}, sale[maxn] = {0};
    int duo = 0, shao = 0;
    string salelist, wantlist;
    // 输入并记录
    cin >> salelist >> wantlist;
    int salelen = int(salelist.length()), wantlen = int(wantlist.length());
    for (int i = 0; i < salelen; i ++) {
        sale[salelist.at(i)] ++;
    }
    for (int i = 0; i < wantlen; i ++) {
        want[wantlist.at(i)] ++;
    }
    // 判断是否足够,如果不够计算少了多少
    bool isok = true;
    for (int i = 0; i < maxn; i ++) {
        if (want[i] == 0)
            continue;
        if (want[i] > sale[i]) {
            isok = false;
            shao += want[i] - sale[i];
        }
    }
    // 如果足够足够计算多了多少并输出
    if (isok) {
        for (int i = 0; i < maxn; i ++) {
            if (sale[i] == 0)
                continue;
            if (sale[i] > want[i]) {
                duo += sale[i] - want[i];
            }
        }
        cout << "Yes " << duo;
    }
    else {
        cout << "No " << shao;
    }
    
    return 0;
}

总结

学习不息,继续加油

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值