【PAT】A1085/B1030 Perfect Sequence【二分查找】

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​^5​​) is the number of integers in the sequence, and p (≤10^​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10^​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

题意

找出一个最大的连续子序列,满足完美序列的定义,输出这个序列的元素个数。

思路

排序后二分查找

代码

#include <cstdio>
#include <algorithm>
#include <cmath>
#define MAX_N 100000
using namespace std;
int main() {
    int N, P;
    int a[MAX_N];
    scanf("%d %d", &N, &P);
    for(int i = 0; i < N; i++){
        scanf("%d", &a[i]);
    }
    sort(a, a + N);
    
    int cnt = 0;
    for(int i = 0, j; i < N; i++){
        // 注意这里的类型转换,避免乘积溢出
        j = (int)(upper_bound(a + i + 1, a + N, (long long)a[i] * P) - a);
        cnt = max(cnt, j - i);
    }
    printf("%d", cnt);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值