【PAT】A1066 Root of AVL Tree【AVL树】

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

题意

给出一组序列,求构建的AVL树的根结点的值。

思路

按AVL树的定义建树,旋转,代码要多次记忆、理解。

代码

#include <cstdio>
#include <algorithm>
using namespace std;
struct Node{
    int value, height;
    Node* left;
    Node* right;
    Node(int value) : left(NULL), right(NULL), value(value), height(1){};
}*root;
int height(Node*x){
    if(x == NULL) return 0;
    return x->height;
}

void updateHeight(Node*x){
    x->height = max(height(x->left), height(x->right)) + 1;
}

int getBalanceFactor(Node* root){
    return height(root->left) - height(root->right);
}

// 左旋转(将不平衡的子树的右子结点作为新的根结点,原来的根节点作为新的左子树)
void L(Node*&root){
    Node* temp = root->right;// 暂存新的根结点为temp
    root->right = temp->left;// 将temp的左子树连接为root的右子树(因为temp为root的右子树,所以它的左子树比root大)
    temp->left = root;// 将root连接到temp的左子树上
    
    // 更新产生变化的两个子树的高度
    updateHeight(root);
    updateHeight(temp);
    
    root = temp;// 改变指针
}

// 右旋转(原理和代码与上面对称)
void R(Node*&root){
    Node* temp = root->left;
    root->left = temp->right;
    temp->right = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp;
}

void insert(Node*&root, int value){
    if(root == NULL){
        root = new Node(value);
        return;
    }
    if(value < root->value){
        insert(root->left, value);
        updateHeight(root);
        if(getBalanceFactor(root) == 2){
            if(getBalanceFactor(root->left) == 1){// 左子树的高度差是1,说明插入结点为左子树的左子结点,右旋。
                R(root);
            }else{// 否则插入结点为左子树的右子结点,先左旋再右旋。
                L(root->left);
                R(root);
            }
        }
    }else{// 和上面对称,但是这个地方是负数
        insert(root->right, value);
        updateHeight(root);
        if(getBalanceFactor(root) == -2){
            if(getBalanceFactor(root->right) == -1){
                L(root);
            }else{
                R(root->right);
                L(root);
            }
        }
    }
}

int main() {
    int N;
    scanf("%d", &N);
    root = NULL;
    for(int i = 0, v; i < N; i++){
        scanf("%d", &v);
        insert(root, v);
    }
    printf("%d\n", root->value);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值