【PAT】A1116 Come on! Let's C【素数】

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
1、 Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
2、 Everyone else will receive chocolates.
Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^​4​​ ), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

题意

给出一个长度为N的排名列表,每个人的ID为四位数字。对于排名的序号,分别为1、素数、既不是1也不是素数这三种情况给出不同的奖品。接着进行K个查询,根据查询的ID分别为不在排名列表、已经检查过、未检查(未检查就输出对应奖品)进行输出。

思路

初始化一维整型数组rankList所有元素为0,将编号为i的人存储在rankList[i]中,rankList中的元素0代表不在数组中,-1代表已检查过,其他数字代表对应排名。首先上手一个欧拉筛法求得从1到N的素数。然后根据题意查询输出(查询过一个有效的ID,则将其排名赋值为-1,这样下次查询时就输出已查询)。

代码

#include <iostream>
#include <algorithm>
#define MAX_N 10001
int ranklist[MAX_N], prime[MAX_N], cnt = 0;
bool marked[MAX_N];
void eulerSeive(int N){
    std::fill(marked, marked + N + 1, false);
    for(int i = 2; i <= N; i++){
        if(!marked[i]){
            prime[cnt++] = i;
        }
        for(int j = 0, p; j < cnt; j++){
            p = prime[j];
            if(i * p > N) break;
            marked[i * p] = true;
            if(i % p == 0) break;
        }
    }
}
int main() {
    std::fill(ranklist, ranklist + MAX_N, 0);
    
    int N;
    scanf("%d", &N);
    for(int i = 1, t; i <= N; i++){
        scanf("%d", &t);
        ranklist[t] = i;
    }
    
    eulerSeive(N);
    
    int K;
    scanf("%d", &K);
    for(int i = 0, r, t; i < K; i++){
        scanf("%d", &t);
        r = ranklist[t];
        if(r == 1){
            printf("%04d: Mystery Award\n", t);
            ranklist[t] = -1;
        }else if(r == 0){
            printf("%04d: Are you kidding?\n", t);
        }else if(r == -1){
            printf("%04d: Checked\n", t);
            ranklist[t] = -1;
        }else if(!marked[r]){
            printf("%04d: Minion\n", t);
            ranklist[t] = -1;
        }else{
            printf("%04d: Chocolate\n", t);
            ranklist[t] = -1;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值