zju 2109 FatMouse' Trade

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1109

 

FatMouse' Trade

Time Limit: 2 Seconds      Memory Limit: 65536 KB

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


Sample Input


5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output

13.333
31.500



Author: CHEN, Yue
Source: Zhejiang Provincial Programming Contest 2004

关键是读懂题目的意思,然后就很容易求了。

先购买单位F中J最多的那个room的J。如果M<J  则按比例购买。

#include <stdio.h>

struct  change
{
  int f,j;
  double s;

}cat[1002];

	int n,m;

void print()
{
	for(int i=1;i<=n;i++)
			printf("%d %d %lf\n",cat[i].j,cat[i].f,cat[i].s);

}

int main()
{
	int i,j;
	double max;
	while(scanf("%d%d",&m,&n)==2&&m>=0)
	{
		max=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&cat[i].j,&cat[i].f);
			cat[i].s=cat[i].j*(1.0)/cat[i].f;
		    j=i;
			while(j>1&&cat[j].s>cat[j-1].s)    //根据比例排序
			{
				struct change tmp;
				tmp=cat[j];
				cat[j]=cat[j-1];
				cat[j-1]=tmp;
				j--;
			}
		}
	//	print();
		for(i=1;i<=n;i++)
		{
			if(cat[i].f>m)
			{
				max+=((double)cat[i].j*m*(1.0)/cat[i].f);
				break;
			}
			else 
			{
				m-=cat[i].f;
				max+=cat[i].j;
			}
		}
		printf("%.3lf\n",max);
	}

  return 0;		
}


 

typedef struct   
{  
    double v;  
    int j,f;  
}Bean;  
Bean bean[1005];  
int cmp( Bean x,Bean y )  
{  
   if( x.v >= y.v )  
       return 1;  
   else  
       return 0;  
}  

  
sort(bean,bean+n,cmp);  
结构体用sort函数排序


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值