HDU4463-Outlets

Outlets

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                      Total Submission(s): 3472    Accepted Submission(s): 1605

Problem Description
In China, foreign brand commodities are often much more expensive than abroad. The main reason is that we Chinese people tend to think foreign things are better and we are willing to pay much for them. The typical example is, on the United Airline flight, they give you Haagendazs ice cream for free, but in China, you will pay $10 to buy just a little cup.
So when we Chinese go abroad, one of our most favorite activities is shopping in outlets. Some people buy tens of famous brand shoes and bags one time. In Las Vegas, the existing outlets can't match the demand of Chinese. So they want to build a new outlets in the desert. The new outlets consists of many stores. All stores are connected by roads. They want to minimize the total road length. The owner of the outlets just hired a data mining expert, and the expert told him that Nike store and Apple store must be directly connected by a road. Now please help him figure out how to minimize the total road length under this condition. A store can be considered as a point and a road is a line segment connecting two stores.
 
Input
There are several test cases. For each test case: The first line is an integer N( 3 <= N <= 50) , meaning there are N stores in the outlets. These N stores are numbered from 1 to N. The second line contains two integers p and q, indicating that the No. p store is a Nike store and the No. q store is an Apple store. Then N lines follow. The i-th line describes the position of the i-th store. The store position is represented by two integers x,y( -100<= x,y <= 100) , meaning that the coordinate of the store is (x,y). These N stores are all located at different place. The input ends by N = 0.
 
Output
For each test case, print the minimum total road length. The result should be rounded to 2 digits after decimal point.
 
Sample Input
  
  
4 2 3 0 0 1 0 0 -1 1 -1 0
 
Sample Output
  
  
3.41
 
Source

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>

using namespace std;

double map[105][105];
double dis[105];
int visit[105];
const int INF=0x3f3f3f3f;
int x[105],y[105];

int main()
{
    int n,p,q;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d %d",&p,&q);
        for(int i=1; i<=n; i++)
            scanf("%d %d",&x[i],&y[i]);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(i==j) map[i][j]=0;
                else map[i][j]=INF;
            }
        }
        double o;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                o=1.0*sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
                map[i][j]=map[j][i]=o;
            }
        }
        memset(visit,0,sizeof visit);
        double sum=0;
        visit[p]=1;
        for(int i=1; i<=n; i++)
            dis[i]=map[p][i];
        visit[q]=1;
        sum+=dis[q];
        for(int i=1;i<=n;i++)
            if(!visit[i]&&dis[i]>map[q][i]) dis[i]=map[q][i];
        for(int i=1; i<n-1; i++)
        {
            double mi=INF;
            int k=-1;
            for(int j=1; j<=n; j++)
                if(!visit[j]&&dis[j]<mi)
                    mi=dis[j],k=j;
            if(k!=-1)
            {
                sum+=mi;
                visit[k]=1;
                for(int j=1; j<=n; j++)
                    if(!visit[j]&&map[k][j]<dis[j])
                        dis[j]=map[k][j];
            }
        }
        printf("%.2lf\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值