HDU2844&&POJ1742-Coins(多重背包)

159 篇文章 1 订阅
63 篇文章 0 订阅

Coins

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                      Total Submission(s): 12634    Accepted Submission(s): 5083

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 
Sample Output
  
  
8 4
 
Source

题意:给你一些不同价值和一定数量的硬币,求用这些硬币可以组合成价值在[1 , m]之间的有多少。

解题思路:a[i]既是物体的体积,又是物体的价值,c[i]是物体的数量,最后判断dp[i]==i是否成立,即判断能否组合成不超过m的任意一个数。本来HDU已经过了,结果发现POJ过不了,又重新写了新的。可以将所有物品都进行二进制优化,或者可以用sum[j]来表示到金额j使用第i种物品的数量


HDU能过的多重背包:

#include <stdio.h>
#include <algorithm>
#include <string.h>

using namespace std;

const int MAX=100000;
int dp[MAX];
int c[MAX],w[MAX];

void ZeroOnePack(int cost,int val,int v)
{
    for(int i=v;i>=cost;i--)
        dp[i]=max(dp[i],dp[i-cost]+val);
}

void CompletePack(int cost,int val,int v)
{
    for(int i=cost;i<=v;i++)
        dp[i]=max(dp[i],dp[i-cost]+val);
}

void MultiplePack(int cost,int val,int cnt,int v)
{
    if(v<=cnt*cost) CompletePack(cost,val,v);
    else
    {
        int k = 1;
        while(k<=cnt)
        {
            ZeroOnePack(k*cost,k*val,v);
            cnt = cnt-k;
            k = 2*k;
        }
        ZeroOnePack(cnt*cost,cnt*val,v);
    }
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&c[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&w[i]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            MultiplePack(c[i],c[i],w[i],m);
        int sum=0;
        for(int i=1;i<=m;i++)
            if(dp[i]==i) sum++;
        printf("%d\n",sum);
    }
    return 0;
}


POJ能过的:

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <cmath>  
#include <map>  
#include <cmath>  
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

bool dp[100010];
int v[110],a[10000],c[110];

int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m)&&n&&m)
	{
		int cnt = 0;
		for (int i = 0; i <= m; i++) dp[i] = 0;
		for (int i = 0; i < n; i++) scanf("%d", &v[i]);
		int num;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &c[i]);
			int k = 1;
			while (k < c[i])
			{
				a[cnt++] = k*v[i];
				c[i] -= k;
				k *= 2;
			}
			a[cnt++] = c[i]*v[i];
		}
		dp[0] = 1;
		for (int i = 0; i < cnt; i++)
			for (int j = m; j >= a[i]; j--)
				if (!dp[j]) dp[j] = dp[j - a[i]];
		int sum = 0;
		for (int i = 1; i <= m; i++)
			if (dp[i]) sum++;
		printf("%d\n", sum);
	}
	return 0;
}


#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <cmath>  
#include <map>  
#include <cmath>  
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

int n, m;
int dp[100010], sum[100010], v[110], c[110];

int main()
{
	while (~scanf("%d%d", &n, &m)&& n && m)
	{
		for (int i = 1; i <= n; i++) scanf("%d", &v[i]);
		for (int i = 1; i <= n; i++) scanf("%d", &c[i]);
		memset(dp, 0, sizeof(dp));
		dp[0] = 1;
		int ans = 0;
		for (int i = 1; i <= n; i++)
		{
			memset(sum, 0, sizeof(sum));
			for (int j = v[i]; j <= m; j++)
			{
				if (!dp[j] && dp[j - v[i]] && sum[j - v[i]] < c[i])
				{
					dp[j] = 1;
					sum[j] = sum[j - v[i]] + 1;
					ans++;
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值