HDU1429-胜利大逃亡(续)

28 篇文章 0 订阅
16 篇文章 0 订阅

胜利大逃亡(续)

                                                                     Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                Total Submission(s): 7963    Accepted Submission(s): 2829

Problem Description
Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)……

这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁的门,钥匙藏在地牢另外的某些地方。刚开始Ignatius被关在(sx,sy)的位置,离开地牢的门在(ex,ey)的位置。Ignatius每分钟只能从一个坐标走到相邻四个坐标中的其中一个。魔王每t分钟回地牢视察一次,若发现Ignatius不在原位置便把他拎回去。经过若干次的尝试,Ignatius已画出整个地牢的地图。现在请你帮他计算能否再次成功逃亡。只要在魔王下次视察之前走到出口就算离开地牢,如果魔王回来的时候刚好走到出口或还未到出口都算逃亡失败。
 
Input
每组测试数据的第一行有三个整数n,m,t(2<=n,m<=20,t>0)。接下来的n行m列为地牢的地图,其中包括:

. 代表路
* 代表墙
@ 代表Ignatius的起始位置
^ 代表地牢的出口
A-J 代表带锁的门,对应的钥匙分别为a-j
a-j 代表钥匙,对应的门分别为A-J

每组测试数据之间有一个空行。
 
Output
针对每组测试数据,如果可以成功逃亡,请输出需要多少分钟才能离开,如果不能则输出-1。
 
Sample Input
  
  
4 5 17 @A.B. a*.*. *..*^ c..b* 4 5 16 @A.B. a*.*. *..*^ c..b*
 
Sample Output
  
  
16 -1
 
Author
LL
 
Source

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <string.h>

using namespace std;

int m,n,t;
char map[25][25];
int visit[25][25][1<<10];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

struct node
{
    int x,y,step;
    int s;
}start,en;

int bfs()
{
    queue<node>q;
    node pre,next;
    q.push(start);
    visit[start.x][start.y][start.s]=1;
    while(!q.empty())
    {
        pre=q.front();
        q.pop();
        if(pre.x==en.x&&pre.y==en.y&&pre.step<t)
            return pre.step;
        int x,y;
        for(int i=0; i<4; i++)
        {
            next.x=x=pre.x+dir[i][0];
            next.y=y=pre.y+dir[i][1];
            next.s=pre.s;
            if(x>=0&&x<m&&y>=0&&y<n&&!visit[x][y][next.s])
            {
                if(map[x][y]=='.'||map[x][y]=='^')
                {
                    next.step=pre.step+1;
                    visit[x][y][next.s]=1;
                    q.push(next);
                }
                else if(map[x][y]>='a'&&map[x][y]<='j')
                {
                    next.s=1<<(map[x][y]-'a')|pre.s;
                    next.step=pre.step+1;
                    visit[x][y][next.s]=1;
                    q.push(next);
                }
                else if(map[x][y]>='A'&&map[x][y]<='J')
                {
                    if(1<<(map[x][y]-'a')&pre.s)
                    {
                        next.step=pre.step+1;
                        visit[x][y][next.s]=1;
                        q.push(next);
                    }
                }
            }

        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d %d %d",&m,&n,&t))
    {
        for(int i=0;i<m;i++)
        {
            scanf("%s",map[i]);
            for(int j=0;j<n;j++)
            {
                if(map[i][j]=='@') start.x=i,start.y=j,start.s=1<<10,start.step=0,map[i][j]='.';
                if(map[i][j]=='^') en.x=i,en.y=j;
            }
        }
        memset(visit,0,sizeof visit);
        printf("%d\n",bfs());
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值