HDU3006-The Number of se

The Number of set

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                       Total Submission(s): 1353    Accepted Submission(s): 835

Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 
Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 
Output
For each case,the output contain only one integer,the number of the different sets you get.
 
Sample Input
  
  
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 
Sample Output
  
  
15 2

题目大意:给定n个集合,每个集合都是由大于等于1小于等于m的数字组成,m最大为14。由给出的集合可以组成多少个不同的集合。
输入描述:第一行为n,m,接下来n行,第一个为k,表示该集合的元素个数,接下来k个数表示集合元素。

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <string.h>

using namespace std;

int a[1<<16];

int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        memset(a,0,sizeof a);
        for(int i=0;i<n;i++)
        {
            int k,p,x=0;
            scanf("%d",&k);
            for(int j=0;j<k;j++)
            {
                scanf("%d",&p);
                x+=(1<<(p-1));
            }
            a[x]=1;
            for(int j=1;j<=(1<<m);j++)
            {
                if(a[j]) a[j|x]=1;
            }
        }
        int ans=0;
        for(int i=1;i<=(1<<m);i++)
            if(a[i]) ans++;
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值