HDU5273-Dylans loves sequence

Dylans loves sequence

                                                                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                                                    Total Submission(s): 1069    Accepted Submission(s): 486

Problem Description
Dylans is given  N  numbers  a[1]....a[N]

And there are  Q  questions.

Each question is like this  (L,R)

his goal is to find the “inversions” from number  L  to number  R .

more formally,his needs to find the numbers of pair( x,y ),
that  Lx,yR  and  x<y  and  a[x]>a[y]
 
Input
In the first line there is two numbers  N  and  Q .

Then in the second line there are  N  numbers: a[1]..a[N]

In the next  Q  lines,there are two numbers  L,R  in each line.

N1000,Q100000,LR,1a[i]2311
 
Output
For each query,print the numbers of "inversions”
 
Sample Input
  
  
3 2 3 2 1 1 2 1 3
 
Sample Output
  
  
1 3
Hint
You shouldn't print any space in each end of the line in the hack data.
 
Source


题意:给定一组数,q次查询(每次区间l~r),输出从x[l] 到x[r] 存在多少对逆序数。

解题思路:dp[l][r]表示从l~r的逆序数对数。


#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>

using namespace std;

int a[1005][1005];
int dp[1005][1005];
int x[1005];

int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&x[i]);
        memset(a,0,sizeof a);
        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++)
        {
            for(int j=i-1;j>0;j--)
            {
                if(x[j]>x[i]) a[j][i]=a[j+1][i]+1;
                else a[j][i]=a[j+1][i];
            }
        }
        for(int i=1;i<=n;i++)
            for(int j=i+1;j<=n;j++)
                dp[i][j]=dp[i][j-1]+a[i][j];
        while(m--)
        {
            int q,w;
            scanf("%d %d",&q,&w);
            printf("%d\n",dp[q][w]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值