HDU3584-Cube

Cube

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
                                                                                                       Total Submission(s): 1939    Accepted Submission(s): 1010

Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].
 
Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.
 
Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)
 
Sample Input
  
  
2 5 1 1 1 1 1 1 1 0 1 1 1 1 1 1 1 2 2 2 0 1 1 1 0 2 2 2
 
Sample Output
  
  
1 0 1
 
Author
alpc32
 
Source

题意:有一个立方体,初始每个格子都为0,可以对格子操作,把0变为1,把1变为0,最后询问某个格子最后的值是多少。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#include <algorithm>

using namespace std;

const int N=110;
int a[N][N][N],n,k;

int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int y,int z)
{
    for(int i=x;i<N;i+=lowbit(i))
    {
        for(int j=y;j<N;j+=lowbit(j))
        {
            for(int p=z;p<N;p+=lowbit(p))
                a[i][j][p]++;
        }
    }
}

int sum(int x,int y,int z)
{
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        for(int j=y;j>0;j-=lowbit(j))
        {
            for(int p=z;p>0;p-=lowbit(p))
                ans+=a[i][j][p];
        }
    }
    return ans;
}

int main()
{
    while(~scanf("%d %d",&n,&k))
    {
        memset(a,0,sizeof a);
        int c,x1,y1,z1,x2,y2,z2;
        for(int i=1; i<=k; i++)
        {
            scanf("%d",&c);
            if(!c)
            {
                scanf("%d %d %d",&x1,&y1,&z1);
                printf("%d\n",sum(x1,y1,z1)%2);
            }
            else
            {
                scanf("%d %d %d %d %d %d",&x1,&y1,&z1,&x2,&y2,&z2);
                add(x1,y1,z1);
                add(x1,y1,z2+1);
                add(x1,y2+1,z1);
                add(x2+1,y1,z1);
                add(x1,y2+1,z2+1);
                add(x2+1,y1,z2+1);
                add(x2+1,y2+1,z1);
                add(x2+1,y2+1,z2+1);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值