HDU1238-Substrings

33 篇文章 0 订阅

Substrings

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                       Total Submission(s): 9866    Accepted Submission(s): 4679

Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 
Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
 
Output
There should be one line per test case containing the length of the largest string found.
 
Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 
Sample Output
  
  
2 2
 
Author
Asia 2002, Tehran (Iran), Preliminary

题思:找出所有字符串中共同拥有的一个子串,该子串(正、逆字符)是任何一个母串的子串,求该子串的最长长度。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#include <algorithm>

using namespace std;

const int INF=0x3f3f3f3f;

int main()
{
    int t,n;
    char str[105][105],s1[105],s2[105];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int mi=INF,p;
        for(int i=0; i<n; i++)
        {
            scanf("%s",str[i]);
            int len=strlen(str[i]);
            if(mi>len)
            {
                mi=len;
                p=i;
            }
        }
        int len1=strlen(str[p]);
        int flag=1;
        int ma=0;
        for(int i=0;i<len1;i++)
        {
            for(int j=i;j<len1;j++)
            {
                flag=1;
                for(int k=i;k<=j;k++)
                {
                    s1[k-i]=str[p][k];
                    s2[j-k]=str[p][k];
                }
                s1[j-i+1]=s2[j-i+1]='\0';
                int len2=strlen(s1);
                for(int k=0; k<n; k++)
                {
                    if(!strstr(str[k],s1)&&!strstr(str[k],s2))
                    {
                        flag=0;
                        break;
                    }
                }
                if(len2>ma&&flag)
                    ma=len2;
            }
        }
        printf("%d\n",ma);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值