ZOJ3331-Process the Tasks(双塔DP)

120 篇文章 1 订阅
66 篇文章 0 订阅

Process the Tasks

Time Limit: 1 Second       Memory Limit: 32768 KB

There are two machines A and B. There are n tasks, namely task 1, task 2, ..., task n. You must assign each task to one machine to process it. There are some facts you must know and comply with:

  • You must assign each task to only one machine to process.
  • At any time, a machine can process at most one task.
  • Task i (0 < i < n) can be processed if and only if each task j (0 < j < i) has been processed or processing.
  • If a task is processing on one machine, it cannot be interrupted.

You want to do finish all the tasks as soon as possible.

Input

There are multiple test cases. The first line of the input is an integer T (0 < T < 1000) indicating the number of test cases. Then T test cases follow. Each test case starts with an integer n (0 < n < 100). The ith line of the next n lines contains two integers tAtB (0 < tAtB < 100), giving the time to process the ith task by machine A and machine B.

Output

For each test case, output the earliest time when all the tasks have been processed.

Sample Input

4
1
1 2
2
1 2
2 1
2
1 2
90 95
3
1 3
1 3
1 3

Sample Output

1
1
90
3

Hints

  • Test case 1: Let machine A process task 1.
  • Test case 2: Let machine A process task 1 and at the same time let machine B process task 2.
  • Test case 3: Let machine B process task 1 and at the same time let machine A process task 2.
  • Test case 4: Let machine A process all the tasks.

Author:  CAO, Peng
Source:  The 7th Zhejiang Provincial Collegiate Programming Contest


题意:有两个机器,A和B,现在有N个任务,每个任务用A机器做需要ai时间,用B机器做需要bi时间。  a,b,n<100,第i个任务只有在第i-1个任务在做或者已经做完才可以开始做,每个机器只能同时做一个任务,问最少需要多少时间能最晚所有任务

解题思路:双塔dp。


首先可以将问题转化为两个塔,塔的高度为在该机器上完成的项目的总时间。

存在两种情况:

  1.工作加在较高的塔上,此时高度差增加,需注意低塔也要增加空闲值(因为那段时间还在处理i-1任务,i任务还没有开始,i+1不可能进行)

  2.工作加在较低的塔上,①低塔变为高塔 ② 低塔仍为低塔

以A塔为高塔为例:

这里写图片描述

ps:高度差 j 为A塔高度减去B塔

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;
const int MAX=100009;

int dp[105][200];//前i项任务,两个机器时间差为j,两塔中较高塔的高度。
int ta[105],tb[105];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int k= 100;//时间差可为正可为负,故增加k保证值为正
        int n;
        scanf("%d",&n);
        for (int i = 1; i <= n; i++)
            scanf("%d %d",&ta[i],&tb[i]);
        for (int i=0;i<=n;i++)
            for (int j=0;j<=200;j++)
                dp[i][j]=INF;
        dp[0][0+k]=0;//没有任务时候,为0
        for(int i=1;i<=n;i++)
        {
            for(int j=-99;j<=99;j++)// 时间差
            {
                if(dp[i-1][j+k]==INF) continue;
                if(j<0)//B塔较高 
                {
                    dp[i][-tb[i]+k]=min(dp[i][-tb[i]+k],dp[i-1][j+k]+tb[i]);//第i项任务放在B塔上
                    dp[i][j+ta[i]+k]=min(dp[i][j+ta[i]+k],dp[i-1][j+k]+max(0,j+ta[i]));//第i项任务放在A塔上,①低塔变成高塔 + j + ta[i];②低塔仍为低塔 + 0(利用了空闲时间,高塔高度不变即dp值不变);   
                }
                else
                {
                    dp[i][ta[i]+k]=min(dp[i][ta[i]+k],dp[i-1][j+k]+ta[i]);
                    dp[i][j-tb[i]+k]=min(dp[i][j-tb[i]+k],dp[i-1][j+k]+max(0,tb[i]-j));
                }
            }
        }
        int ans=INF;
        for (int i=-99;i<=99;i++)
            ans=min(dp[n][i+k],ans);
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值