HDU2888-Check Corners(RMQ)

63 篇文章 0 订阅
29 篇文章 0 订阅

Check Corners

                                                                       Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                    Total Submission(s): 2847    Accepted Submission(s): 1010


Problem Description
Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)
 

Input
There are multiple test cases. 

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer. 

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question. 
 

Output
For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.
 

Sample Input
  
  
4 4 4 4 10 7 2 13 9 11 5 7 8 20 13 20 8 2 4 1 1 4 4 1 1 3 3 1 3 3 4 1 1 1 1
 

Sample Output
  
  
20 no 13 no 20 yes 4 yes
 

Source
 

Recommend
gaojie
 

         题意:输入一个矩阵,然后再输入Q条指令,每条指令是一个子矩阵的两个对角顶点,让求这个子矩阵元素的最大值。然后看这个最大值和子矩阵的4个顶点有没有相同的,如果有,再输出“yes”,没有输出“no”。

       解题思路:RMQ


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;
int dp[305][305][9][9];
int a[305][305];
int n,m;

void init_rmq()
{
    for(int i=1; i<=n; i++)
        for(int j=1; j<=m; j++)
            dp[i][j][0][0]=a[i][j];
    int k1=(int)(log((double)n)/log(2.0));
    int k2=(int)(log((double)m)/log(2.0));
    for(int i=0; i<=k1; i++)
    {
        for(int j=0; j<=k2; j++)
        {
            if(i==0&&j==0) continue;
            for(int r=1; r+(1<<i)-1<=n; r++)
            {
                for(int c=1; c+(1<<j)-1<=m; c++)
                {
                    if(i==0) dp[r][c][i][j]=max(dp[r][c][i][j-1],dp[r][c+(1<<(j-1))][i][j-1]);
                    else dp[r][c][i][j]=max(dp[r][c][i-1][j],dp[r+(1<<(i-1))][c][i-1][j]);
                }
            }
        }
    }
}

int RMQ(int r1,int c1,int r2,int c2)
{
    int k1=(int)(log(double(r2-r1+1))/log(2.0));
    int k2=(int)(log(double(c2-c1+1))/log(2.0));
    return max(max(dp[r1][c1][k1][k2],dp[r2-(1<<k1)+1][c1][k1][k2]),max(dp[r1][c2-(1<<k2)+1][k1][k2],dp[r2-(1<<k1)+1][c2-(1<<k2)+1][k1][k2]));
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                scanf("%d",&a[i][j]);
        init_rmq();
        int t,r1,c1,r2,c2;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d %d %d %d",&r1,&c1,&r2,&c2);
            int ans=RMQ(r1,c1,r2,c2);
            printf("%d ",ans);
            if(ans==a[r1][c1]||ans==a[r1][c2]||ans==a[r2][c1]||ans==a[r2][c2]) printf("yes\n");
            else printf("no\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值