1010. Radix (25)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:6 110 1 10Sample Output 1:
2Sample Input 2:
1 ab 1 2Sample Output 2:
Impossible
题意:给定两个数,其中单个位置上的数值范围可以为 [a-z]。指定其中一个数的进制,试确定是否存在可能的进制让两数的实际值相等
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ull unsigned long long
string a,b;
int t;
ull ans,l,r,sum,ra;
ull get(char ch)
{
if('0'<=ch&&ch<='9') return ch-'0';
return ch-'a'+10;
}
int main()
{
cin>>a>>b>>t>>ra;
if(t==2) swap(a,b);
sum=0,l=0;
for(int i=0;a[i];i++)
sum=sum*ra+get(a[i]);
for(int i=0;b[i];i++)
l=max(l,get(b[i]));
l++,r=sum+1;
int res=-1;
while(l<=r)
{
ull mid=(l+r)>>1;
ull ans=0;
for(int i=0;b[i];i++)
ans=ans*mid+get(b[i]);
if(ans==sum)
res=mid;
if(ans>=sum) r=mid-1;
else l=mid+1;
}
if(res==-1) printf("Impossible\n");
else printf("%d\n",res);
return 0;
}