POJ1325&&ZOJ1364-Machine Schedule

120 篇文章 1 订阅
30 篇文章 0 订阅

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14798 Accepted: 6318

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source


题意:机器a有n种工作模式,机器b有m种工作模式,有k个任务,每个任务可以在机器a的第i种模式进行或机器b的第j种模式进行,一开始两种机器都在模式0下运行,问一共要调整几次机器的工作方式才能是使所有任务完成

解题思路:二分图,点覆盖数=匹配数(边独立数),点覆盖数就是选最少的点使得所有的边至少有一个顶点属于所选点,即用最少的点覆盖所有的边(对于那些能在机器a或机器b模式0下进行的任务是不需要调整机器工作方式的)

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int n;
int x[205],y[205];
int xn,yn;
int s[2050],nt[2050],e[2050];
int visit[205];

bool path(int k)
{
    for(int i=s[k];~i;i=nt[i])
    {
        int ee=e[i];
        if(ee==0) continue;
        if(!visit[ee])
        {
            visit[ee]=1;
            if(!y[ee]||path(y[ee]))
            {
                y[ee]=k;
                x[k]=ee;
                return 1;
            }
        }
    }
    return 0;
}

void MaxMatch()
{
    int ans=0;
    memset(x,0,sizeof x);
    memset(y,0,sizeof y);
    for(int i=1;i<=xn;i++)
    {
        if(!x[i])
        {
            memset(visit,0,sizeof visit);
            if(path(i)) ans++;
        }
    }
    printf("%d\n",ans);
}

int main()
{
    while(~scanf("%d",&xn)&&xn)
    {
        scanf("%d %d",&yn,&n);
        int cnt=1,ss,ee,kk;
        memset(s,-1,sizeof s);
        memset(nt,-1,sizeof nt);
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d",&kk,&ss,&ee);
            nt[cnt]=s[ss],s[ss]=cnt,e[cnt++]=ee;
        }
        MaxMatch();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值