ZOJ1119&&POJ1523-SPF(求割点)

120 篇文章 1 订阅
63 篇文章 0 订阅

SPF
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8584 Accepted: 3916

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source


题意:给你一个图,去掉哪几个点后图会变成两个以上的重联通分量

解题思路:求割点


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

const int N=1010;

int edge[N][N];
int n,son;
int subnet[N],dfn[N],low[N],tmpdfn;
bool vis[N];

void init()
{
    tmpdfn=1,son=0;
    memset(dfn,0,sizeof dfn);
    memset(low,0,sizeof low);
    memset(vis,0,sizeof vis);
    memset(subnet,0,sizeof subnet);
}

void dfs(int u)
{
    low[u]=dfn[u]=tmpdfn++;
    vis[u]=true;
    for(int v=1;v<=n;v++)
    {
        if(edge[u][v])
        {
            if(!vis[v])
            {
                dfs(v);
                low[u]=min(low[u],low[v]);
                if(low[v]>=dfn[u])
                {
                    if(u!=1) subnet[u]++;
                    else son++;
                }
            }
            else low[u]=min(low[u],dfn[v]);
        }
    }
}

int main()
{
    int cas=0;
    int u,v;
    while(~scanf("%d",&u))
    {
        n=0;
        if(u==0) break;
        memset(edge,0,sizeof edge);
        scanf("%d",&v);
        n=max(n,u);
        n=max(n,v);
        edge[u][v]=edge[v][u]=1;
        while(1)
        {
            scanf("%d",&u);
            if(u==0) break;
            scanf("%d",&v);
            n=max(n,u);
            n=max(n,v);
            edge[u][v]=edge[v][u]=1;
        }
        if(cas) printf("\n");
        printf("Network #%d\n", ++cas);
        init();
        dfs(1);
        if(son>1) subnet[1]=son-1;
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            if(subnet[i])
            {
                flag=1;
                printf("  SPF node %d leaves %d subnets\n",i,subnet[i]+1);
            }
        }
        if(!flag) printf("  No SPF nodes\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值