zstu-4270同源数

4270: 同源数

Time Limit: 3 Sec   Memory Limit: 128 MB
Submit: 1377   Solved: 261

Description

如果x和y的质因子集合完全相同,那么我们就说他们是同源的。
比如说18 = 2 * 3 2,12 = 3 * 2 2

Input

本题有多组数据(组数 <= 555555)。
每组数据输入形如:
x y
x, y为整数(1 <= x, y <= 1e18)

Output

输出形入:
ans
如果x, y为同源数,那么ans为”Yes”, 不然为”No”.

Sample Input

18 12
2 3

Sample Output

Yes
No

HINT

Source


解题思路:求出两个数的gcd,两个数除以gcd后得到的数,不断地和gcd求gcd,并除以求得gcd,看能否变为1


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <bitset>
#include <stack>
#include <map>
#include <climits>
#include <functional>
 
using namespace std;
 
#define LL long long
const int INF=0x3f3f3f3f;
 
LL gcd(LL a,LL b)
{
    if(a>b) swap(a,b);
    while(b%a)
    {
        LL k=b%a;
        b=a;
        a=k;
    }
    return a;
}
 
int main()
{
    LL x,y;
    while(~scanf("%lld%lld",&x,&y))
    {
        LL k=gcd(x,y);
        x/=k,y/=k;
        int flag=1;
        while(x!=1)
        {
            int kk=gcd(x,k);
            x/=kk;
            if(kk==1) break;
        }
        while(y!=1)
        {
            int kk=gcd(y,k);
            y/=kk;
            if(kk==1) break;
        }
        if(x!=1||y!=1) printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值