The summer training of ZJU ICPC in July is about to end. To celebrate this great and happy day, the coach of ZJU ICPC Team decided to BG everyone!
After a brief discussion, they decided to go to Lou Wai Lou to have a great dinner. Each team member can bring some friends with him/her. Of course, they need to tell the coach the number of friends they will bring.
Now the coach wants to know the total number of participants (excluding the coach himself). Please tell him.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains an integer N (1 <= N <= 40) - the number of ZJU ICPC members.
The second line contains N non-negative integers, the i-th integer indicates the number of friends (< 1000) that the i-th team member will bring.
Output
For each test case, output the total number of participants.
Sample Input
4 5 0 0 1 2 3 1 0 10 1 2 3 4 5 6 7 8 9 10 2 5 3
Sample Output
11 1 65 10
Author: DAI, Longao
Source: The 13th Zhejiang Provincial Collegiate Programming Contest
题意:有n个人去参加晚宴,他们每个人带a[i]个朋友去,问一共有几个热呢参加晚宴
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>
using namespace std;
#define LL long long
const int INF = 0x3f3f3f3f;
int main()
{
int t;
scanf("%d",&t);
while (t--)
{
int n,k;
scanf("%d", &n);
int ans = n;
for (int i = 0; i < n; i++)
{
scanf("%d", &k);
ans += k;
}
printf("%d\n", ans);
}
return 0;
}