PAT (Advanced Level) Practise 1127 ZigZagging on a Tree (30)

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15


题意:给你一棵树的中序遍历和后序遍历,求出这棵树的前序遍历

解题思路:dfs


#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <cmath>  
#include <map>  
#include <cmath>  
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

int n;
int a[35],b[35],son[35][2],ans[35],c[35];

int dfs(int l, int r, int ll, int rr)
{
	if (l > r || ll > r) return 0;
	for (int i = l; i <= r; i++)
	{
		if (b[rr] == a[i])
		{
			son[rr][0] = dfs(l, i - 1,ll ,i-l+ll-1);
			son[rr][1] = dfs(i + 1, r, i - l + ll, rr - 1);
		}
	}
	return rr;
}

int main()
{
	while (~scanf("%d", &n))
	{
		for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
		for (int i = 1; i <= n; i++) scanf("%d", &b[i]);
		dfs(1, n, 1, n);
		queue<int>q;
		int cnt = 1,now=0;
		q.push(n);
		while (!q.empty())
		{
			int sum = 1;
			while (!q.empty())
			{
				int pre = q.front();
				q.pop();
				c[sum++] = pre;
			}
			if (!now)
			{
				for (int i = sum - 1; i >= 1; i--)
					ans[cnt++] = c[i];
			}
			else
			{
				for (int i = 1; i < sum; i++)
					ans[cnt++] = c[i];
			}
			now ^= 1;
			for (int i = 1; i < sum; i++)
			{
				if (son[c[i]][0]) q.push(son[c[i]][0]);
				if(son[c[i]][1]) q.push(son[c[i]][1]);
			}
		}
		for (int i = 1; i <= n; i++) printf("%d%c", b[ans[i]], i == n ? '\n' : ' ');
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值