PAT (Advanced Level) Practise 1110 Complete Binary Tree (25)

1110. Complete Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

题意:一棵树有n个节点,告诉你各个节点的左右孩子,问这棵树是不是完全二叉树,若是,输出最后一个点的编号,若不是,输出根节点

解题思路:首先建树后,没有作为叶子节点的一定是根节点,然后算所有点的标号,若最大为n,则是完全二叉树


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, son[25][2],visit[25];

int main()
{
	while (~scanf("%d", &n))
	{
		memset(visit, 0, sizeof visit);
		for (int i = 0; i < n; i++)
		{
			char s1[5], s2[5];
			scanf("%s%s", &s1, &s2);
			int a = 0, b = 0,len1=strlen(s1),len2=strlen(s2);
			if (s1[0] != '-')
			{
				for (int j = 0; j < len1; j++) a = a * 10 + s1[j] - '0';
				son[i][0] = a;
				visit[a] = 1;
			}
			else son[i][0] = -1;
			if (s2[0] != '-')
			{
				for (int j = 0; j < len2; j++) b = b * 10 + s2[j] - '0';
				son[i][1] = b;
				visit[b] = 1;
			}
			else son[i][1] = -1;
		}
		int ma = 1,k,ans;
		for (int i = 0; i < n; i++)
			if (!visit[i]) k = i;
		queue<pair<int, int> >q;
		q.push(make_pair(k, 1));
		while (!q.empty())
		{
			pair<int, int>pre = q.front();
                        q.pop();
			if (pre.second == n) ans = pre.first;
			ma = max(ma, pre.second);
			if (son[pre.first][0] != -1) q.push(make_pair(son[pre.first][0],pre.second*2));
			if (son[pre.first][1] != -1) q.push(make_pair(son[pre.first][1], pre.second * 2+1));
		}
		if (ma == n) printf("YES %d\n", ans);
		else printf("NO %d\n", k);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值