PAT (Advanced Level) Practise 1091 Acute Stroke (30)

1091. Acute Stroke (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.


Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26

题意:给出4个正整数:M、N、L、T,其中M和N是每张切片的尺寸(即每张切片是一个M×N的像素矩阵。最大分辨率是1286×128);L(<=60)是切片的张数;T是一个整数阈值(若疑似肿瘤的连通体体积小于T,则该小块忽略不计)。给定病灶扫描切片中标注出的疑似肿瘤区域,计算出肿瘤的体积。给出L张切片。每张用一个由0和1组成的M×N的矩阵表示,其中1表示疑似肿瘤的像素,0表示正常像素。由于切片厚度可以认为是一个常数,只要数连通体中1的个数就可以得到体积了。可能存在多个肿瘤,只统计那些体积不小于T的。两个像素被认为是“连通的”,如果它们有一个共同的切面


#include <iostream>  
#include <cstdio>  
#include <string>  
#include <cstring>  
#include <algorithm>  
#include <cmath>  
#include <queue>  
#include <vector>  
#include <set>  
#include <stack>  
#include <map>  
#include <climits>  
  
using namespace std;  
  
#define LL long long  
  
const int INF=0x3f3f3f3f;  
  
int a[65][1300][135];  
bool visit[65][1300][135];  
int n,m,l,k;  
int sum;  
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};  
  
struct node  
{  
    int x,y,z;  
}pre,nt;  
  
void bfs(int z,int x,int y)  
{  
    queue<node>q;  
    pre.z=z,pre.x=x,pre.y=y;  
    visit[z][x][y]=1;  
    q.push(pre);  
    int ans=0;  
    while(!q.empty())  
    {  
        ans++;  
        pre=q.front();  
        q.pop();  
        for(int i=0;i<6;i++)  
        {  
            int xx=pre.x+dir[i][0];  
            int yy=pre.y+dir[i][1];  
            int zz=pre.z+dir[i][2];  
            if(zz<1||zz>l||xx<1||xx>m||yy<1||yy>n||visit[zz][xx][yy]||!a[zz][xx][yy]) continue;  
            nt.x=xx,nt.y=yy,nt.z=zz;  
            visit[zz][xx][yy]=1;  
            q.push(nt);  
        }  
    }  
    if(ans>=k) sum+=ans;  
}  
  
int main()  
{  
    while(~scanf("%d %d %d %d",&m,&n,&l,&k))  
    {  
        sum=0;  
        for(int i=1; i<=l; i++)  
            for(int j=1; j<=m; j++)  
                for(int k=1; k<=n; k++)  
                    scanf("%d",&a[i][j][k]);  
        memset(visit,0,sizeof visit);  
        for(int i=1;i<=l;i++)  
        {  
            for(int j=1;j<=m;j++)  
            {  
                for(int k=1;k<=n;k++)  
                {  
                    if(!a[i][j][k]||visit[i][j][k]) continue;  
                    bfs(i,j,k);  
                }  
            }  
        }  
        printf("%d\n",sum);  
    }  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值