HDU6077-Time To Get Up

234 篇文章 1 订阅

Time To Get Up

                                                                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
                                                                                            Total Submission(s): 548    Accepted Submission(s): 438


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38
 

Source
 

题意:将给出的字符转化为数字

解题思路:每个数字找出一些特殊点进行判断即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const LL mod = 998244353;

char ch[10][50];

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		for (int i = 0; i<7; i++) scanf("%s", ch[i]);
		int a[5],p=1;
		for (int i = 0; i < 4; i++)
		{
			if (ch[0][p] == 'X')
			{
				if (ch[1][p-1] == 'X')
				{
					if (ch[1][p+2] == 'X')
					{
						if (ch[3][p] == '.') a[i] = 0;
						else if (ch[4][p-1] == 'X') a[i] = 8;
						else a[i] = 9;
					}
					else if (ch[4][p-1] == 'X') a[i] = 6;
					else a[i] = 5;
				}
				else if (ch[3][p] == '.') a[i] = 7;
				else if (ch[4][p-1] == 'X') a[i] = 2;
				else a[i] = 3;
			}
			else if (ch[3][p] == 'X') a[i] = 4;
			else a[i] = 1;
			if (i == 1) p += 7;
			else p += 5;
		}
		printf("%d%d:%d%d\n", a[0], a[1], a[2], a[3]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值