HDU6090-Rikka with Graph

216 篇文章 0 订阅

Rikka with Graph

                                                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                               Total Submission(s): 794    Accepted Submission(s): 452


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph  G  with  n  nodes and  m  edges, we can define the distance between  (i,j)  ( dist(i,j) ) as the length of the shortest path between  i  and  j . The length of a path is equal to the number of the edges on it. Specially, if there are no path between  i  and  j , we make  dist(i,j)  equal to  n .

Then, we can define the weight of the graph  G  ( wG ) as  ni=1nj=1dist(i,j) .

Now, Yuta has  n  nodes, and he wants to choose no more than  m  pairs of nodes  (i,j)(ij)  and then link edges between each pair. In this way, he can get an undirected graph  G  with  n  nodes and no more than  m  edges.

Yuta wants to know the minimal value of  wG .

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose  (1,2),(1,4),(2,4),(2,3),(3,4) .
 

Input
The first line contains a number  t(1t10) , the number of the testcases. 

For each testcase, the first line contains two numbers  n,m(1n106,1m1012) .
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
  
  
1 4 5
 

Sample Output
  
  
14
 

Source
 


题意:给出n个点,在它们之间加入m条边,使得任意两点的距离和最小(两点距离为两点之间的最短路,一条边的距离为1,两点之间不能达到则距离为n)

解题思路:先随意找一个根节点,在m足够大的条件下,将它和其他所有点相连,则此时答案为2*(n-1)*(n-1),若边有多余,则在除根节点的任意两点之间加边,每加一条边答案减2



#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <unordered_map>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

LL n,m;

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lld %lld", &n, &m);
        LL sum = 0;
        if(m >= n - 1)
        {
            m = min(m, n * (n - 1) / 2);
            sum += 2 * (n - 1) * (n - 1);
            m -= n - 1;
            sum -= m * 2;
        }
        else
        {
            sum += 2 * m * m;
            sum += (m + 1) * (n - m -1) * n;
            sum += (n - m -1) * n * (n - 1);
        }
        printf("%lld\n", sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值