HDU6148-Valley Numer

Valley Numer

                                                                   Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                             Total Submission(s): 477    Accepted Submission(s): 252


Problem Description
众所周知,度度熊非常喜欢数字。

它最近发明了一种新的数字:Valley Number,像山谷一样的数字。




当一个数字,从左到右依次看过去数字没有出现先递增接着递减的“山峰”现象,就被称作 Valley Number。它可以递增,也可以递减,还可以先递减再递增。在递增或递减的过程中可以出现相等的情况。

比如,1,10,12,212,32122都是 Valley Number。

121,12331,21212则不是。

度度熊想知道不大于N的Valley Number数有多少。

注意,前导0是不合法的。
 

Input
第一行为T,表示输入数据组数。

每组数据包含一个数N。

● 1≤T≤200

● 1≤length(N)≤100
 

Output
对每组数据输出不大于N的Valley Number个数,结果对 1 000 000 007 取模。
 

Sample Input
  
  
3 3 14 120
 

Sample Output
  
  
3 14 119
 

Source
 

解题思路:数位dp


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const LL mod = 1e9 + 7;

char ch[105];
int a[105];
LL dp[105][15][5];

LL dfs(int pos, int pre, int sta, bool limit)
{
    if (pos == -1)
    {
        if (!sta) return 0;
        return 1;
    }
    if (!limit&&dp[pos][pre][sta] != -1) return dp[pos][pre][sta];
    int up = limit ? a[pos] : 9;
    LL ans = 0;
    for (int i = 0; i <= up; i++)
    {
        if (sta == 2 && pre <= i) (ans += dfs(pos - 1, i, sta, limit&&i == up)) %= mod;
        if (sta == 1)
        {
            if (pre >= i) (ans += dfs(pos - 1, i, sta, limit&&i == up)) %= mod;
            else (ans += dfs(pos - 1, i, 2, limit&&i == up)) %= mod;
        }
        if (sta == 0)
        {
            if (i == 0) (ans += dfs(pos - 1, i, 0, limit &&i == up)) %= mod;
            else (ans += dfs(pos - 1, i, 1, limit&&i == up)) %= mod;
        }
    }
    if (!limit) dp[pos][pre][sta] = ans;
    return ans;
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        memset(dp, -1, sizeof dp);
        scanf("%s", ch);
        int len = strlen(ch);
        for (int i = 0; i < len; i++) a[i] = ch[len - i - 1] - '0';
        printf("%lld\n", dfs(len - 1, 0, 0, 1));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值