HDU6187-Destroy Walls

Destroy Walls

                                                                         Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
                                                                                                   Total Submission(s): 272    Accepted Submission(s): 117


Problem Description
Long times ago, there are beautiful historic walls in the city. These walls divide the city into many parts of area. 

Since it was not convenient, the new king wants to destroy some of these walls, so he can arrive anywhere from his castle. We assume that his castle locates at  (0.62,0.63)

There are  n  towers in the city, which numbered from 1 to n. The ith's location is  (xi,yi) . Also, there are m walls connecting the towers. Specifically, the ith wall connects the tower  ui  and the tower  vi (including the endpoint). The cost of destroying the ith wall is  wi

Now the king asks you to help him to divide the city. Firstly, the king wants to destroy as less walls as possible, and in addition, he wants to make the cost least. 

The walls only intersect at the endpoint. It is guaranteed that no walls connects the same tower and no 2 walls connects the same pair of towers. Thait is to say, the given graph formed by the walls and towers doesn't contain any multiple edges or self-loops.

Initially, you should tell the king how many walls he should destroy at least to achieve his goal, and the minimal cost under this condition.
 

Input
There are several test cases.

For each test case:

The first line contains 2 integer n, m.

Then next n lines describe the coordinates of the points.

Each line contains 2 integers  xi,yi

Then m lines follow, the ith line contains 3 integers  ui,vi,wi

|xi|,|yi|105

3n100000,1m200000

1ui,vin,uivi,0wi10000
 

Output
For each test case outout one line with 2 integers sperate by a space, indicate how many walls the king should destroy at least to achieve his goal, and the minimal cost under this condition. 
 

Sample Input
  
  
4 4 -1 -1 -1 1 1 1 1 -1 1 2 1 2 3 2 3 4 1 4 1 2
 

Sample Output
  
  
1 1
 

Source
 

Recommend
liuyiding
 

题意:有一个n个结点m条边的带边权无向平面图,有一个人在一个区域,要拆一些墙使得他可以到达任意一个区域,问最小花费

解题思路:生成一棵最大生成树即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cctype>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const int maxn = 1e5 + 10;

int n, m, x, y,f[100009];
struct node
{
	int u, v;
	LL w;
	bool operator<(const node &a)const
	{
		return w > a.w;
	}
}a[200009];

int Find(int x)
{
	return f[x] == x ? x : f[x] = Find(f[x]);
}

int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		LL ans = 0;
		for (int i = 1; i <= n; i++) scanf("%d%d", &x, &y);
		for (int i = 1; i <= m; i++) scanf("%d%d%lld", &a[i].u, &a[i].v, &a[i].w),ans+=a[i].w;
		sort(a + 1, a + 1 + m);
		for (int i = 1; i <= n; i++) f[i] = i;
		int cnt = 0;
		for (int i = 1; i <= m; i++)
		{
			int uu = Find(a[i].u), vv = Find(a[i].v);
			if (uu == vv) { cnt++; continue; }
			f[uu] = vv;
			ans -= a[i].w;
		}
		printf("%d %lld\n", cnt, ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值