HDU3966-Aragorn's Story

Aragorn's Story

                                                                      Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                              Total Submission(s): 13173    Accepted Submission(s): 3519


Problem Description
Our protagonist is the handsome human prince Aragorn comes from The Lord of the Rings. One day Aragorn finds a lot of enemies who want to invade his kingdom. As Aragorn knows, the enemy has N camps out of his kingdom and M edges connect them. It is guaranteed that for any two camps, there is one and only one path connect them. At first Aragorn know the number of enemies in every camp. But the enemy is cunning , they will increase or decrease the number of soldiers in camps. Every time the enemy change the number of soldiers, they will set two camps C1 and C2. Then, for C1, C2 and all camps on the path from C1 to C2, they will increase or decrease K soldiers to these camps. Now Aragorn wants to know the number of soldiers in some particular camps real-time.
 

Input
Multiple test cases, process to the end of input.

For each case, The first line contains three integers N, M, P which means there will be N(1 ≤ N ≤ 50000) camps, M(M = N-1) edges and P(1 ≤ P ≤ 100000) operations. The number of camps starts from 1.

The next line contains N integers A1, A2, ...AN(0 ≤ Ai ≤ 1000), means at first in camp-i has Ai enemies.

The next M lines contains two integers u and v for each, denotes that there is an edge connects camp-u and camp-v.

The next P lines will start with a capital letter 'I', 'D' or 'Q' for each line.

'I', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, increase K soldiers to these camps.

'D', followed by three integers C1, C2 and K( 0≤K≤1000), which means for camp C1, C2 and all camps on the path from C1 to C2, decrease K soldiers to these camps.

'Q', followed by one integer C, which is a query and means Aragorn wants to know the number of enemies in camp C at that time.
 

Output
For each query, you need to output the actually number of enemies in the specified camp.
 

Sample Input
  
  
3 2 5 1 2 3 2 1 2 3 I 1 3 5 Q 2 D 1 2 2 Q 1 Q 3
 

Sample Output
  
  
7 4 8
Hint
1.The number of enemies may be negative. 2.Huge input, be careful.
 

Source
 


题意:一颗树上,每个点有权值,定义三种操作:I操作表示从a到b节点之间的节点都加上一个值,D操作表示从a到b节点之间的节点的都减去一个权值,Q操作询问a节点当前的值

解题思路:树链剖分



#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, m, x, y, z;
int s[100009], nt[100009], e[100009], v[100009], cnt;
int ct[100009], mx[100009], fa[100009], dep[100009];
int top[100009], sum[100009], g[100009];
char ch[100009];

int lowbit(int x)
{
	return x&-x;
}

void add(int x, int y)
{
	while (x<=n)
	{
		sum[x] += y;
		x += lowbit(x);
	}
}

int getsum(int x)
{
	int res = 0;
	while (x)
	{
		res += sum[x];
		x -= lowbit(x);
	}
	return res;
}

void dfs(int x, int f)
{
	dep[x] = dep[f] + 1;
	fa[x] = f; ct[x] = 1; mx[x] = 0;
	for (int i = s[x]; ~i; i = nt[i])
	{
		if (e[i] == f) continue;
		dfs(e[i], x);
		ct[x] += ct[e[i]];
		if (ct[e[i]] > ct[mx[x]]) mx[x] = e[i];
	}
}

void Dfs(int x, int t)
{
	top[x] = !t ? x : top[fa[x]];
	g[x] = ++cnt;
	add(cnt, v[x]);
	add(cnt + 1, -v[x]);
	if (mx[x]) Dfs(mx[x], 1);
	for (int i = s[x]; ~i; i = nt[i])
	{
		if (e[i] == fa[x]) continue;
		if (e[i] == mx[x]) continue;
		Dfs(e[i], 0);
	}
}

void change(int x, int y, int z)
{
	while (top[x] != top[y])
	{
		if (dep[top[x]] < dep[top[y]]) swap(x, y);
		add(g[top[x]], z);
		add(g[x] + 1, -z);
		x = fa[top[x]];
	}
	if (dep[x] > dep[y]) swap(x, y);
	add(g[x], z); add(g[y] + 1, -z);
}

int main()
{
	while (~scanf("%d%d%d", &n, &m, &m))
	{
		for (int i = 1; i <= n; i++) scanf("%d", &v[i]), s[i] = -1, sum[i] = 0;
		dep[0] = ct[0] = cnt = 0;
		for (int i = 1; i < n; i++)
		{
			scanf("%d%d", &x, &y);
			nt[cnt] = s[x], s[x] = cnt, e[cnt++] = y;
			nt[cnt] = s[y], s[y] = cnt, e[cnt++] = x;
		}
		dfs(1, 0);
		Dfs(1, cnt = 0);
		while (m--)
		{
			scanf("%s", ch);
			if (ch[0] == 'Q')
			{
				scanf("%d", &x);
				printf("%d\n", getsum(g[x]));
			}
			else
			{
				scanf("%d%d%d", &x, &y, &z);
				change(x, y, ch[0] == 'I' ? z : -z);
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值