uva_1583_Digit Generator

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

input

Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the input. Each test case takes one line containing an integer N , 1$ \le$N$ \le$100, 000 .

output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.

The following shows sample input and output for three test cases.

Sample input

3 
216 
121 
2005

Sample output

198 
0 
1979
 
思路:
一开始想输入一个数从1开始算一个数,超时了;看了书后,看到打表,然后自己写了一个,从1开始算每一个数的生成元,结果跑的时间太长了;在看书上的代码之后,尼玛倒着来的。
代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int a[100005];
void gen()
{
    int i,x,y;
    memset(a,0,sizeof(a));
    for(i=1;i<100005;i++)
    {
        x=i;
        y=i;
        while(x) {y+=x%10;x/=10;}
        if(a[y]==0||i<a[y])
            a[y]=i;
    }
}
int main()
{
    int m,n;
    scanf("%d",&m);
    gen();
    while(m--)
    {
        scanf("%d",&n);
        printf("%d\n",a[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值