uva_1584_Circular Sequence

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence ``CGAGTCAGCT", that is, the last symbol ``T" in ``CGAGTCAGCT" is connected to the first symbol ``C". We always read a circular sequence in the clockwise direction.

\epsfbox{p3225.eps}

Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

intput

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ACG and T, are allowed. Each sequence has length at least 2 and at most 100.

output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

The following shows sample input and output for two test cases.

sample input

2                                     
CGAGTCAGCT                            
CTCC

sample output

AGCTCGAGTC 
CCCT
思路:
一开始读题以为是求逆序数最小的一个,写出代码之后发现不对,字典序不是这个意思,看了紫书才知道字典序的意思,长知识了。就利用strcmp函数比较就行,不断移位然后求出一个最小的输出就行。
字典序:“一般地,对于两个字符串,如果从第一个字符开始比较,当某个位置的字符不同时,该位置字符较小的串,字典序较小;如果其中一个字符串已经没有更多字符,但另一个字符串还没有结束,则较短的字符串的字典序较小。”——————引自刘汝佳《算法竞赛入门经典(第2版)》
代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

void yw(char d[])
{
    char t;
    t=d[0];
    int i;
    for(i=0;i<strlen(d);i++)
    {
        if(i==strlen(d)-1) d[i]=t;
        else d[i]=d[i+1];
    }
}

int main()
{
    int t,i;
    char d[105],a[105];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",d);
        strcpy(a,d);
        for(i=1;i<=strlen(a);i++)
        {
            if(strcmp(a,d)>0)
                strcpy(a,d);
            yw(d);
        }
        puts(a);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值