hdoj 1394 Minimum Inversion Number(树状数组求逆序对)

Minimum Inversion Number


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source

sum记录初始的逆序对数
之后对sum逆序循环操作  循环到i表示处理将第i个数从数列末尾调到开头的情况
总共有n个数,对于数a[i]在数列末尾时前面比他大的个数为n-a[i]-1,比他小的个数为a[i] 
当把a[i]调到开头时原先比他大的(n-a[i]-1)个所构成的逆序对变成正序 故sum-n+a[i]+1
原先比a[i]小的a[i]个正序对变成逆序对 故(sum-n+a[i]+1)+a[i]
循环一遍 取最小的sum 就是答案
#include<cstdio>
#include<cstring>
using namespace std;
#define lowbit(x) x&(-x)
#define N 5000+5
#define INF 1000000000
int cnt[N];
int add(int n)
{
    while(n<=N)
    {
        cnt[n]++;
        n+=lowbit(n);
    }
    return 0;
}
int query(int n)
{
    int sum=0;
    while(n>0)
    {
        sum+=cnt[n];
        n-=lowbit(n);
    }
    return sum;
}
int main()
{
    int a[N],n,sum,i,min;
    while(scanf("%d",&n)!=EOF)
    {
        min=INF;
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sum=0;
        memset(cnt,0,sizeof(cnt));
        for(i=1;i<=n;i++)
        {
            add(a[i]+1);
            sum+=i-query(a[i]+1);
        }
        for(i=n;i>1;i--)
        {
            sum=sum-n+1+2*a[i];
            if(sum<min)
                min=sum;
        }
        printf("%d\n",min);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值